поиск значения по 2-м условиям и подстановка по наибольшему условию

Автор Аиша, 18.04.2012, 10:45

« назад - далее »

Аиша

Доброе утро!
помогите пожалуйста решить задачу: нужно найти ФИО по номеру телефона и последней дате:
во вложении на листе "монтеры" нужно найти и проставить на лист "заявки" фамилию монтера, при совпадении номера телефона, а если их несколько, то с наибольшей датой столбца "B" листа "монтеры".

Serge 007

Так можно:
=ИНДЕКС(монтеры!$B$2:$C$6;СУММПРОИЗВ(МАКС(($A2=монтеры!$A$2:$A$6)*СТРОКА($1:$5)));ПОИСКПОЗ(C$1;монтеры!$B$1:$C$1;))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Аиша

Цитата: Serge 007 от 18.04.2012, 11:12
Так можно:
=ИНДЕКС(монтеры!$B$2:$C$6;СУММПРОИЗВ(МАКС(($A2=монтеры!$A$2:$A$6)*СТРОКА($1:$5)));ПОИСКПОЗ(C$1;монтеры!$B$1:$C$1;))

Спасибо! подогнала под рабочйй файл, отлично получилось!
правда, давно не могу понять как работает в таких случаях "суммпроизв"... и вообще с умножением при поиске не догоняю...

Serge 007

Цитата: Аиша от 18.04.2012, 13:55
...не могу понять как работает в таких случаях "суммпроизв"...
Так же как и в остальных случаях :)
Сначала массивы перемножаются, потом суммируются.

Цитата: Аиша от 18.04.2012, 13:55
... и вообще с умножением при поиске не догоняю...
При поиске умножение не используется.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390