ВПР не дает правильный результат

Автор Legre, 03.05.2012, 10:30

« назад - далее »

Legre

Добрый день!

Помогите с простым случаем применения ВПР, пожалуйста!

Имеется таблица значений, вот такой фрагмент:
0,60   1,1225
0,61   1,1296
0,62   1,1369
0,63   1,1444
0,64   1,1521
0,65   1,1600

Первый столбец отсортирован по возрастанию, повторов значений нет.
Формула, где применяется ВПР следующая: =ВПР(D14;tgf!A4:B204;2;0)
D14 вычисляется по следующей формуле: =ОКРУГЛ((D7+E7+F7+G7)/(D8+E8+F8+G8);2) и равно 0,62

Так вот, если интервальный просмотр ИСТИНА (или отсутствует), то получаем 1,1296 - это значение соответствует 0,61, что не верно; а если поставить ЛОЖЬ (или 0), то получаем #Н/Д...

Форматы чисел вроде бы правильные стоят. Пробовал таблицу перезаписывать через "копировать->специальная вставка->значения" - не помогает.



Barbarian12

Когда интервальный просмотр стоит ИСТИНА, функция ВПР ищет приблизительное значение. При ЛОЖЬ - ищется точное соответствие и, если искомое значение не найдено, возвращается соответствующая ошибка. Прикрепите файл, чтобы можно было посмотреть как именно выглядит таблица.

Legre

Случайно нашел решение проблемы:

Преобразовал таблицу через округление первого столбца до двух знаков после запятой. И ВПР заработала правильно! Теперь её копия (колонки C и D) "нравятся" ВПР-у. И все-таки интересно, в чем прикол?

cheshiki1

в вашем приложенном файле нет полной картины происходящего, а то что там есть прекрасно работает с ВПР без ОКРУГЛ.

_Boroda_

#4
Цитата: cheshiki1 от 03.05.2012, 11:59
в вашем приложенном файле нет полной картины происходящего, а то что там есть прекрасно работает с ВПР без ОКРУГЛ.
Ничего подобного. Поищите 0,83

Посмотрите на 15-й знак после запятой. Например, в А86
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

cheshiki1

#5
_Boroda_  точно, а я так далеко не полез посмотрел в первой двадцатке произвольно.
ну тогда естественно что впр выдал Н/д число то не совпадает.

Barbarian12

#6
Цитата: Legre от 03.05.2012, 11:37
Случайно нашел решение проблемы:

Преобразовал таблицу через округление первого столбца до двух знаков после запятой. И ВПР заработала правильно! Теперь её копия (колонки C и D) "нравятся" ВПР-у. И все-таки интересно, в чем прикол?

В таком случае можно вашу формулу ВПР записать следующим образом (вводить как массив), чтобы она сама округляла значения в искомой таблице без доп столбцов:
{=ВПР(D14;ОКРУГЛ(tgf!A4:B204;4);2;0)}

Legre

Благодарю вас за разъяснения.
Хотя не понятно, откуда EXCEL придумал лишние знаки, если столбец формировался автоматически через инкремент на 0,01 с последующим преобразование результата в чистые значения.. Но, это не важно, - уже работает и ладушки!
Спасибо за участие в решении проблемы.