Сформировать столбец сог-но значениям из другого

Автор Verter, 04.05.2012, 09:08

« назад - далее »

Verter

Здравствуйте!
Собственно вопрос в файле. Подозреваю что это можно сделать без макроса, да вот что то никак не получается. Желательно что бы операция выполнялась одной формулой, что бы созданному массиву можно было присвоить имя.
Спасибо.

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

cheshiki1

Serge 007 судя по описанию в файле там пустые во второй строке не нужно учитывать.
формула массива =ИНДЕКС($D$2:$CI$2;НАИМЕНЬШИЙ(ЕСЛИ($D$3:$CI$3>"";СТОЛБЕЦ($D$3:$CI$3));СТРОКА(1:1))-3)

Verter

#3
Цитата: cheshiki1 от 04.05.2012, 10:01
формула массива =ИНДЕКС($D$2:$CI$2;НАИМЕНЬШИЙ(ЕСЛИ($D$3:$CI$3>"";СТОЛБЕЦ($D$3:$CI$3));СТРОКА(1:1))-3)

Спасибо. То что надо. Только пришлось немного изменить:
=ТРАНСП(ИНДЕКС($D$2:$CI$2;НАИМЕНЬШИЙ(ЕСЛИ($D$3:$CI$3>"";СТОЛБЕЦ($D$3:$CI$3));СТОЛБЕЦ(1:1))-3))

Wasilic

Цитата: Verter от 04.05.2012, 09:08
Желательно что бы операция выполнялась одной формулой,
Ну что же все так макросов боятся, все равно ведь придется изучать. Формулами не всегда можно обойтись.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.