Слова

Автор _AL_, 04.05.2012, 13:09

« назад - далее »

_AL_

Всем привет!
Как заменить каждую букву в слове на определенную цифру и сосчитать сумму?
Например дано слово МОЛОКО. Меняем М=2, О=1, Л=2, О=1, К=3, О=1. Сумма 10
Спасибо

Poltava

Интересное желание :) но для этого нужно знать что на что менять (то есть должна быть таблица соответствий) если да то тогда через впр можно ну а если макросом то тоже можно но опять таки таблица соответствий нужна да и не помешало бы знать куда писать результат. В общем пример давайте.
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

_AL_

В столбце А список слов.
В столбец В записать результаты
Правее я привел соответствия букв и цифр
Можно макросом
Спасибо

_Boroda_

=СУММ(ЕЧИСЛО(ПОИСК(ПСТР(A2;СТОЛБЕЦ(ДВССЫЛ("C1:C"&ДЛСТР(A2);));1);($E$1:$E$5)))*($F$1:$F$5))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

_AL_

Посмотрел Ваш файл.
Что то не правильно получилось  :(
должно быть ДОМ - 5; (2+1+2); ФЛЮГЕР - 28; (10+2+10+3+1+2)
и т.д.

Poltava

#5
В файле все правильно
А у вас наверно ДОМ 2 флюгер 0 ???
Если да то читайте про формулы массива(ctrl+shift+enter) иначе пишите что именно у вас нетак
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

_Boroda_

Цитата: _AL_ от 04.05.2012, 15:07
Посмотрел Ваш файл.
Что то не правильно получилось  :(
должно быть ДОМ - 5; (2+1+2); ФЛЮГЕР - 28; (10+2+10+3+1+2)
и т.д.
Не понял! А у меня сколько? Или (как уже Poltava догадался) Сначала все правильно, а потом, когда Вы пытаетесь что-то изменить, все сбивается?
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995