Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Сумма определённых значений из таблиц

Автор mildronat, 24.05.2012, 18:44

« назад - далее »

mildronat

Вообщем беда такая: есть 2-е таблицы, в первой есть столбец с датой(дд.мм.гггг) и строка с 24-я часами, в самой матрице значения. И есть вторая таблица (как бы параметры поиска) с столбцом дат и столбцом часов (для каждой даты одно время). Задача: отобрать значения заданные во второй таблице из первой матрицы и сложить их, ну и показать где-то.
Ка кто-так. но лучше пример: снизу.
Заранее спасибо!

Serge 007

Конкретно для Вашего примера:
=ИНДЕКС($B$2:$Y$13;СТРОКА(A1);AB17)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

mildronat

#2
Я дико извеняюся, ощибочка в условие. даты во второй таблице(таблица параметров поиска) не подряд. Буду крайне признателен если найдётся решение для такого варианта

DV68

Сумма одной формулой:
=СУММПРОИЗВ(Ч(СМЕЩ(A1;ПОИСКПОЗ(AA17:AA23;A2:A13;);AB17:AB23)))

Serge 007

Никак не возьму в толк, зачем нужна сумма, если дни и часы не повторяются?

Можно так:
=ИНДЕКС(B$2:Y$13;ПОИСКПОЗ(AA17;A$2:A$13);AB17)
или для конкретного месяца так:
=ИНДЕКС(B$2:Y$13;ДЕНЬ(AA17);AB17)

А сумму по любому можно найти так ("нелетуче"):
=СУММПРОИЗВ((B$1:Y$1=AB17)*(AA17=A$2:A$13)*B$2:Y$13)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

DV68

Цитата: mildronat от 24.05.2012, 18:44...
Задача: отобрать значения заданные во второй таблице из первой матрицы и сложить их...
Сергей, нужна не сумма по любому, а сумма найденых значений.