Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Как сделать, чтоб изодной таблицы данные сортировались и суммировались в другую

Автор Евгений00, 01.06.2012, 12:08

« назад - далее »

Евгений00

Добрый день, помогите пожалуйста! Как сделать, чтоб из одной таблицы данные сортировались и суммировались в другую. Допустим в примере Пупкин встречается несколько раз, как сделать, чтоб на втором листе в таблице считалась автоматически сумма Излишек и сумма сколько должен и само сортировалось по месяцам. Допустим первую таблицу я веду сам, а во второй чтоб автоматически всё сортировалось и считалось

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390


Barbarian12

Или формулой. Если оффис 2007, то также подойдет формула (по идее должна работать, на работе 2003 стоит):
=СУММЕСЛИМН(Таблица!$D$2:D10;Таблица!$C$2:C10;результат!A3;Таблица!B2:B10;результат!;ТЕКСТ(A1;"ММММ"))

Poltava

можно и так для 2003 офиса
=СУММПРОИЗВ(--(СМЕЩ(Таблица!$B$1;1;;СЧЁТЗ(Таблица!$B:$B)-1;1)=СТРОЧН(ЛЕВСИМВ($A$1;НАЙТИ(" ";$A$1;2)-1)));--(СМЕЩ(Таблица!$C$1;1;;СЧЁТЗ(Таблица!$C:$C)-1;1)=$A3);СМЕЩ(Таблица!D$1;1;;СЧЁТЗ(Таблица!D:D)-1;1))
Но это так длинно конкретно под ваш случай! где приходиться переводить для проверки месяца в нижний регистр и обрезать год, и к тому же вместо формул СМЕЩ() вычисляющих размеры вашей таблицы можно использовать либо прямые ссылки либо загнать их в именованные диапазоны тогда формула сократиться до такой
=СУММПРОИЗВ(--(Тмесяц=$A$6);--(Тимя=$A8);Тдолг)
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Евгений00

Спасибо большое, с помощью формулы намного интереснее)). У меня excel 2007