Выбор нужного значения из исходной таблицы

Автор Zaparich, 02.06.2012, 21:46

« назад - далее »

Zaparich

Всем привет!

Нужна ваша помощь.

У меня есть исходная таблица с заданными параметрами (заливка серым цветом в файле). Данная исходная таблица нужна для автоматического заполнения ячеек (выделено желтым в файле) другой таблицы в которой информация заносится вручную (выделено синим). Автоматическое заполнение осуществляется поиском нужного значения в исходной таблице. Достаточно сложно объяснить, поэтому я очень просто и наглядно отобразил пример того, что необходимо в результате в приложенном файле. Мне нужна формула для ячеек, куда инфо заполняется автоматически, причем именно формула, а не макрос.

Буду очень признателен за помощь.

Спасибо,
Сергей

ZORRO2005

#1
В ячейку J3:
=ИНДЕКС(D:D;МАКС(($A$3:$A$9=G3)*($B$3:$B$9=H3)*($C$3:$C$9<=I3)*СТРОКА($A$3:$A$9)))
формула массива

P.S.
Странно, но на другом форуме вы подписались как Александр.
Яндекс-деньги: 410011658492153

Zaparich

Благодарю за ответ!
В приложенно вами файлы ваши данные (красная заливка) не совпадают с данными, которые должны получится в итоге (желтая заливка), это так, или у меня файл как-то коряво открылся?
Спасибо!

ZORRO2005

#3
В предыдущем файле была ошибка.
С вашими данными все равно не сходится.

Исходная таблица
Группа 1 Подгруппа 2
01.05.2012 - ближайшая дата к 05.06.2012
04.07.2012
12.04.2012
Яндекс-деньги: 410011658492153

Zaparich

огромное спасибо!
теперь все сходится (1ую строчку это я действительно неверно указал)
и еще одно небольшое уточнение :) а как скопировать формулу массива на все строки сразу (если их будет больше), но так чтобы без применения таблицы (всмысле через "вставка" => "таблица")?

ZORRO2005

Цитата: Zaparich от 03.06.2012, 00:03
как скопировать формулу массива на все строки сразу (если их будет больше), но так чтобы без применения таблицы (всмысле через "вставка" => "таблица")?
Просто потянуть ячейку вниз за правый нижний угол.
Яндекс-деньги: 410011658492153

Zaparich


Zaparich

Добрый день, и снова вопрос ))

Как к уже существующей формуле массива добавить доп.параметры, такие как:
* или если в колонке "Группа" внесена "Группа 3", тогда вместо формулы массива оставляем пустую ячейку ""
* или если в колонке "Вид" внесено "RE", тогда вместо формулы массива также оставляем пустую ячейку ""

Я могу это сделать только с применением доп.колонок (как я это сделал в прикрепленном файле - см. колонки "N" и "O"), хотелось бы данные параметры использовать в тойже колонке, где забита формула массива (колонки "K" и "L").

В прикрепленном файле добавил как раз колонку "Вид".
Буду признателен за помощь.

Спасибо!

ZORRO2005

#8
K2:
=ЕСЛИ(ИЛИ($G3="RE";$H3="Группа 3");"";
ИНДЕКС(D:D;МАКС(($A$3:$A$9=$H3)*($B$3:$B$9=$I3)*($C$3:$C$9=МАКС(($A$3:$A$9=$H3)
*($B$3:$B$9=$I3)*($C$3:$C$9<=$J3)*$C$3:$C$9))*СТРОКА($A$3:$A$9))))

формула массива
Яндекс-деньги: 410011658492153

Zaparich

Спасибо!!
Просто плохо знаю массивы ))
Кстати если в курсе, посоветуйте что можно почитать про массивы в инете, так чтобы с примерами?

ZORRO2005

Цитата: Zaparich от 10.06.2012, 16:03
Кстати если в курсе, посоветуйте что можно почитать про массивы в инете, так чтобы с примерами?
http://www.planetaexcel.ru/tip.php?aid=124
Яндекс-деньги: 410011658492153

Zaparich