Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

ВОПРОС ПО УСЛОВИЮ к ЕСЛИ?

Автор STEROID, 03.06.2012, 20:14

« назад - далее »

STEROID

РЕБЯТА все просто, две таблицы- одна источник, воторая заполняется - цель автоматически расставлять исполнителей, 3 варианта развития событий:
1) если есть материал и исполнитель - прописывается исполнитель
2) если есть материал но нет исполнителя - пишется 0 - соответственно по условию пропиис. "НОВЫЙ ИСПОЛНИТЕЛЬ ИЛИ МАТЕРИАЛ"
3) если нет материала и исполнителя - пишется #НД - соответственно по условию пропиис. "НОВЫЙ ИСПОЛНИТЕЛЬ ИЛИ МАТЕРИАЛ"
Продумал формулу =ЕСЛИ(ИЛИ(ЕОШИБКА(ВПР(A6;$D$2:$E$10;2;ЛОЖЬ))=ИСТИНА();(ВПР(A6;$D$2:$E$10;2;ЛОЖЬ)=0));"НОВЫЙ ИСПОЛНИТЕЛЬ ИЛИ МАТЕРИАЛ";ВПР(A6;$D$2:$E$10;2;ЛОЖЬ))
ВСЕ по отдельности работает (ЕОШИБКА(ВПР(A6;$D$2:$E$10;2;ЛОЖЬ))=ИСТИНА() и (ВПР(A6;$D$2:$E$10;2;ЛОЖЬ)=0, но вместе с функцией ИЛИ не работает в чем дело???

Serge 007

Так надо?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

STEROID

Цитата: Serge 007 от 03.06.2012, 20:34
Так надо?

ХМ, все верно по заданному условию, помогите еще доработать
1) если есть материал и исполнитель - прописывается исполнитель
2) если есть материал но нет исполнителя - пишется 0 - соответственно по условию пропиис. "НОВЫЙ ИСПОЛНИТЕЛЬ"
3) если нет материала и исполнителя - пишется #НД - соответственно по условию пропиис. "НОВЫЙ МАТЕРИАЛ"


Serge 007

=ЕСЛИ(ЕНД(ВПР(A2;D$2:E$10;2;));"новый материал";ЕСЛИ(ВПР(A2;D$2:E$10;2;)=0;"новый исполнитель";ВПР(A2;D$2:E$10;2;)))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

STEROID

Спасибо ваш ответ полностью решил мою проблему, ЕНД - изучу, СПАСИБО!

ПОДСКАЖИТЕ еще такой вопрос: я очень хочу в совершенстве овладеть EXCEL, очень нравится создавать интересные отчеты и таблицы, может есть интересная литература или ссылки на текстовые или видео уроки - ЧТО ВЫ ПОРЕКОМЕНДУЕТЕ, в частности макросов, у вас на сайте только один урок...

Serge 007

Цитата: STEROID от 03.06.2012, 23:16
...я очень хочу в совершенстве овладеть EXCEL...
Это невозможно...
Книги читайте здесь
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

STEROID

СПАСИБО ОЧЕНЬ ПОЛЕЗНЫЙ САЙТ!!!