Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Удаление значения из ячейки B1 в тексте ячейки A1

Автор r-T, 04.06.2012, 12:04

« назад - далее »

r-T

Всем доброго дня!
Долго бьюсь с данной проблемой, но решение найти так и не удалось.
Итак, имеется 2 столбца:
1) Наименование товара с артикулом
2) Отдельно этот же артикул

Задача: автоматизировать удаление артикула из столбца с наименованием товара, т.е. столбца №1. Обобщу: нужно, чтобы excel сам убирал из наименования товара артикул, забирая его значение в соседнем столбце №2, оставляя в столбце А только само наименование без артикула.

NooBasTiK

Оставить именно в столбце А через формулы не получиться, если только рядом где то и потом заменить

r-T

Цитата: NooBasTiK от 04.06.2012, 12:10
Оставить именно в столбце А через формулы не получиться, если только рядом где то и потом заменить

Ну можно тогда и в столбце С оставить наименование уже без артикула. Это возможно?

NooBasTiK

Да конечно можно решений масса скажем так. Попробую свой вариант сделать, если вы выложите файл excel где делать надо (хотя бы часть исходника)

IKor

В том случае если артикул встречается в строке более чем ОДНАЖДЫ, то можно:
1. поменять местами исходные столбцы
2. в третьем столбце записать формулу
Цитировать=ЕСЛИ(ЕОШИБКА(ПОИСК($A15;B15));B15;СЖПРОБЕЛЫ(ЗАМЕНИТЬ(B15;ПОИСК($A15;B15);ДЛСТР($A$15);"")))
которая заменяет пустотой текст из столбца А, найденный в столбце В, а потом удаляет сдвоенные пробелы.
3. копировать ее столбцы правее таблицы столько раз, чтобы удалить все вхождения артикула в столбце с названием
4. Скопировать и ВСТАВИТЬ ТОЛЬКО ЗНАЧЕНИЯ из последнего столбца в исходный столбец.
5. удалить вспомогательные столбцы

Если же артикул встречается в функции только единожды, то менять местами исходные столбцы необязательно, а функцию можно существенно упростить. Попробуйте сделать это самостоятельно - если не получится - обращайтесь.

Barbarian12

Цитата: r-T от 04.06.2012, 12:04
Всем доброго дня!
Долго бьюсь с данной проблемой, но решение найти так и не удалось.
Итак, имеется 2 столбца:
1) Наименование товара с артикулом
2) Отдельно этот же артикул

Задача: автоматизировать удаление артикула из столбца с наименованием товара, т.е. столбца №1. Обобщу: нужно, чтобы excel сам убирал из наименования товара артикул, забирая его значение в соседнем столбце №2, оставляя в столбце А только само наименование без артикула.
Самый простой вариант:
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;B1;""))

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

r-T

NooBasTiK, IKor, Barbarian12, Serge 007 - спасибо Вам!  :D