Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Суммирование данных в двухмерном массиве по трём признакам: ДАТА, АРТИКУЛ , КОД

Автор iwald, 08.06.2012, 13:06

« назад - далее »

iwald

Помогите плиз,  написать в эксэль 2010 формулу для решения  такой задачи :

Дано:
календарный план отгрузки продукции с номенклатурой изделий (по артикулу груза /столбец В/ и коду отправителя/столбец С/.( лист "календарь"))

Требуется:
при ручном вводе даты в числовом виде в ячейку В1( лист "отгрузки"), на этом-же листе необходимо просуммировать в соотв. ячейках столбца В отгрузки в указанный день месяца/ячейка В1/ по каждой из номенклатур изделий по 2 признакам: артикул /столбец С /  и код /столбец D /.
ОСОБОЕ УСЛОВИЕ: в  номенклатуре изделий ( лист "календарь") неоднократно повторяются изделия, ОДИНАКОВЫЕ (выделено цветом) по артикулу груза /столбец В/ и коду отправителя/столбец С/. Значения отгрузок в указанное число месяца-  НУЖНО ПРОСУММИРОВАТЬ.


Попытки найти решение с помощью функций СУММЕСЛИМН и ИНДЕКС/ПОИСКПОЗ  пока не увенчались успехом...
В лучшем случае - возвращается значение, равное не СУММЕ значений ВСЕХ предоставленных в списке изделий с одинаковыми артикулами и кодами, а значение ОДНОЙ ячейки в перечне  отгруженных в указанные сутки изделий.

Возможно ли решение такой задачи без применения макросов?  т.к .с оными (макросами) у меня совсем плохо.

Serge 007

=СУММПРОИЗВ((календарь!B$11:B$21=C2)*(D2=календарь!C$11:C$21)*(ДЕНЬ(B$1)=календарь!H$10:AL$10)*(календарь!H$11:AL$21))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

iwald

Цитата: Serge 007 от 08.06.2012, 13:35
=СУММПРОИЗВ((календарь!B$11:B$21=C2)*(D2=календарь!C$11:C$21)*(ДЕНЬ(B$1)=календарь!H$10:AL$10)*(календарь!H$11:AL$21))


Как говорят у нас в Одессе - "...и шо Ты знаешь? Таки - ДА, работает!!!!..." :D
Огромная Вам благодарность за оказанную в кратчайшие сроки помощь! 8) 8) 8)