Вложенные логические функции

Автор zaja2000, 13.06.2012, 23:00

« назад - далее »

zaja2000

Не могу написать формулу для вывода информации при определённом количестве баллов. Может кто поможет?

cheshiki1

проверяйте
=ЕСЛИ(D31<=120;"Не аттестован по разделу БД";ЕСЛИ(ИЛИ(И(D31<=140;D14<=30);И(D31<=140;D21<=40);И(D31<=140;D30<=55));"Условно аттестован с доработкой раздела № "&ЕСЛИ(D14<=30;1;ЕСЛИ(D21<=40;2;3));"Аттестован по разделу БД"))

ShAM

Так:
=ЕСЛИ(D31<120;"Не аттестован по разделу БД";ЕСЛИ(D31>=140;"Аттестован по разделу БД";"Условно аттестован с доработкой раздела № "&ЕСЛИ(D14<30;1;ЕСЛИ(D21<40;2;3))))
покороче  :)
Только вопрос, что делать если во втором случае в 2-х или даже в 3-х темах баллы меньше, чем надо (например, 29, 39, 54 соответственно)? Их все нужно запихнуть в "Условно аттестован с доработкой раздела №..."?

IKor

Цитата: ShAM от 14.06.2012, 12:48
Только вопрос, что делать если во втором случае в 2-х или даже в 3-х темах баллы меньше, чем надо (например, 29, 39, 54 соответственно)? Их все нужно запихнуть в "Условно аттестован с доработкой раздела №..."?
можно доработать Вашу формулу так:
=ЕСЛИ(D31<120;"Не аттестован по разделу БД";ЕСЛИ(D31>=140;"Аттестован по разделу БД";"Условно аттестован с доработкой разделов: № "&СЖПРОБЕЛЫ(ТЕКСТ(1*(D14<30);"#")&" "&ТЕКСТ(2*(D21<40);"#")&" "&ТЕКСТ(2*(D30<55);"#"))))