Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Отображение значений предпоследних ячеек

Автор s1910197, 14.06.2012, 07:16

« назад - далее »

s1910197

Доброго времени суток! Проблема в следующем... Есть столбец в который ежедневно вводятся цифровые данные в зависимости от дня недели (присутствуют пустые ячейки) Нужна формула для отображения значения только предпоследней не пустой ячейки, по мере заполнения столбца...
Заранеее благодарю

cheshiki1

формула массива
=ИНДЕКС(R[-27]C:R[-3]C;НАИБОЛЬШИЙ((R[-27]C:R[-3]C<>"")*СТРОКА(R[-27]C:R[-3]C);2))

_Boroda_

В принципе, то же самое
=ИНДЕКС(A1:A25;НАИБОЛЬШИЙ(ЕЧИСЛО(A1:A25)*СТРОКА(A1:A25);2))
Написал только для того, чтобы предупредить - будете задваивать, а уж тем более, затраивать, темы - забаню.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

s1910197

Спасибо всем, кто так оперативно откликнулся, но формула не работает... Давайте посмотрим на конкретном примере (см. вложение)

cheshiki1

в данном случае нужно так
=ИНДЕКС(L11:L35;НАИБОЛЬШИЙ((L11:L35<>"")*СТРОКА(L11:L35);2)-10)
формула массива вводится ctrl+shift+enter

s1910197

В принципе разобрался... Но всё ж благодарю всех откликнувшихся...
Окончательно выглядит так: =ИНДЕКС(L11:L35;НАИБОЛЬШИЙ((L11:L35<>"")*СТРОКА(L11:L35);2)-6)
из-за скрываемых строк...