Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Работа с базой данных.

Автор Nurikus, 18.06.2012, 20:08

« назад - далее »

Nurikus

Есть очень большой список аппаратов с их выручкой, данные из системы выгружаются ежедневно. Хочу прописать формулу чтобы в тотальной таблицы она по названию аппарата вытаскивала его выручку из нужного листа. Как такое сделать?
Попробовал функцию ВПР, не получилось. :-[

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

ZORRO2005

Попробуйте СУММЕСЛИ.
Яндекс-деньги: 410011658492153

shamilganiev

вопрос: как точно будут подписаны листы? просто месяц.год или день.месяц.год? и как будут подписаны названия столбцов в тотал?

shamilganiev

Посмотри, примерно так?

Nurikus

Цитата: shamilganiev от 19.06.2012, 09:11
Посмотри, примерно так?
Работает, а можно к примеру данную операцию сделать через функцию ВПР или ГПР?
За помощь спасибо!

shamilganiev

к сожаленью я не пользовался данными функциями, но насколько я смутно знаю про эти функции, то можно. может кто другой форумчанин поможет...

Nurikus

Цитата: shamilganiev от 19.06.2012, 09:02
вопрос: как точно будут подписаны листы? просто месяц.год или день.месяц.год? и как будут подписаны названия столбцов в тотал?
Страницы могут быть подписаны по разному, столбцы тоже. Возможно это будет аналитика по дням.

Serge 007

Цитата: Nurikus от 19.06.2012, 09:58
...можно к примеру данную операцию сделать через функцию ВПР?
=ВПР($B5;ДВССЫЛ("'"&Total!C$4&"'!b2:c300");2;)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

IKor

Цитата: ZORRO2005 от 18.06.2012, 22:27
Попробуйте СУММЕСЛИ.
Одной СУММЕСЛИ() не обойтись.
Я рекомендую попробовать еще ДВССЫЛ() :)

Пример в файле основан на том, что в заголовках Тотальной таблицы указаны точные названия заранее подготовленных именованных диапазонов данных.

Если диапазонов будет много и возиться с отдельным именованием каждого не хочется, то я рекомендую придумать правило их именования и мало-мало автоматизировать аргументы ДВССЫЛ() :)

shamilganiev

Цитата: IKor от 19.06.2012, 10:21
Цитата: ZORRO2005 от 18.06.2012, 22:27
Попробуйте СУММЕСЛИ.
Одной СУММЕСЛИ() не обойтись.
Я рекомендую попробовать еще ДВССЫЛ() :)

Пример в файле основан на том, что в заголовках Тотальной таблицы указаны точные названия заранее подготовленных именованных диапазонов данных.

Если диапазонов будет много и возиться с отдельным именованием каждого не хочется, то я рекомендую придумать правило их именования и мало-мало автоматизировать аргументы ДВССЫЛ() :)
как ты из ДВССЫЛ("янв2012") получаешь '01.2012'!B2:C263 ?
научи а

Serge 007

Цитата: shamilganiev от 19.06.2012, 10:40
как ты из ДВССЫЛ("янв2012") получаешь '01.2012'!B2:C263 ?

Цитата: IKor от 19.06.2012, 10:21
Пример в файле основан на том, что в заголовках Тотальной таблицы указаны точные названия заранее подготовленных именованных диапазонов данных.

shamilganiev, Ctrl+F3 нажмите
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Nurikus

Цитата: Serge 007 от 19.06.2012, 10:17
Цитата: Nurikus от 19.06.2012, 09:58
...можно к примеру данную операцию сделать через функцию ВПР?
=ВПР($B5;ДВССЫЛ("'"&Total!C$4&"'!b2:c300");2;)
Как вы подвязали диапазон b2:c300 к странице 01.2012!
Помогите плиз!

Serge 007

Цитата: Nurikus от 19.06.2012, 10:52
Как вы подвязали диапазон b2:c300 к странице 01.2012!
Nurikus, Вы по ссылке, что я дал в первом своём посте этой темы, ходили?
Там всё подробно и с картинками
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

cheshiki1

ЦитироватьКак вы подвязали диапазон b2:c300 к странице 01.2012!
походу Вы про ф-цию СЦЕПИТЬ в исполнении & не знаете.
два значения (текст или число не важно) можно сцепить:
так =СЦЕПИТЬ(A1;A2) или так  =A1&A2