Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Цена-Количество-Стоимость по нескольким условиям

Автор Che79, 25.06.2012, 18:25

« назад - далее »

Che79

Всем привет!
Что-то подвис над простой задачкой....
Есть количество, есть цена за единицу. Необходимо посчитать стоимость в зависимости от нескольких условий цены и количества. Буду очень признателен, если кто-то откликнется. Пример приложен, задача в нем описана.
Спасибо :)
Делай нормально и будет нормально!

ZORRO2005

Che79,
Попробуйте такую формулу:
=СУММ((AI7:AK7*B7+AL7:AN7*C7)*ЕСЛИ(И(B6=1;C6=1);ПСТР(AI6:AK6;1;2);ЕСЛИ(И(B6=60;C6=60);ПСТР(AI6:AK6;1;2)/60;AI4:AK4)))
формула массива
Яндекс-деньги: 410011658492153

Che79

спасибо, то что нужно! всё прекрасно работает!!!
Делай нормально и будет нормально!

IKor

Если еще актуально.
Раз Вы все-равно используете вспомогательные ячейки AI4:AN4
и поскольку условия результирующей функции привязаны не к текущей строке (седьмая и ниже), а к заголовку (B6:C6),
то зачем Вам проводить сравнение =ЕСЛИ(...;...;ЕСЛИ(...;...;...)) в каждой строке?

Предлагаю конструкцию =ЕСЛИ(...;...;ЕСЛИ(...;...;...)) перенести в ячейки AI4:AN4, в которых генерировать заведомо цифровые значения для каждого из трех случаев, а результирующую формулу для каждой из строк упростить до
=СУММ(СУММПРОИЗВ($AI$4:$AK$4;AI7:AK7)*B7;СУММПРОИЗВ($AL$4:$AN$4;AL7:AN7)*C7)/$B$6