Как удалить одинаковые ячейки из двух заданных столбцов

Автор ardent, 26.06.2012, 13:16

« назад - далее »

ardent

Суть задачи.
В двух столбцах убрать одинаковые ячейки, а уникальные оставить. Скорее всего это можно сделать формулой, а не макросом.

пример.
Есть два столбца:

a   b
b   c
c   d

нужно что бы осталось только а и d,  т.е. именно те значения, которых нету ни в 1м ни во 2м столбце.

exceleved

Допустим, данные в столбцах А и В. В С1 и D1 введите формулы=ЕСЛИ(ЕНД(ВПР(A1;B:B;1;));A1;#Н/Д)
=ЕСЛИ(ЕНД(ВПР(B1;A:A;1;));B1;#Н/Д)
и "растяните" вниз.
Скопируйте столбцы С и D, спец. вставка - значения.
F5 - выделить - константы - ошибки, правый клик - удалить - ячейки, со сдвигом вверх.

ardent


Serge 007

Ещё вариант, одной формулой (см. вложение)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

IKor

Я бы предложил воспользоваться функцией =СЧЁТЕСЛИ()>1, т.к. область ее просмотра не ограничена одним столбцом.
Возможно, Сергей именно это и предлагает - за отсутствием Экселя на данном компе проверить это я не могу :)

Serge 007

Цитата: IKor от 27.06.2012, 06:59
Я бы предложил воспользоваться функцией =СЧЁТЕСЛИ()>1 ...

Возможно, Сергей именно это и предлагает...
Верно :)
Только одной формулой и без допстолбцов
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390