Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Подстановка данных для непустых

Автор Natalia, 07.07.2012, 13:18

« назад - далее »

Natalia

Уважаемые форумчане!
Вроде-бы не сложная задачка. Можно ли с помощью формул подставить только те данные, в одной строке с которыми есть значения.
Выкладываю маленький примерчик. На самом деле таблицы большие, моделей много, подставлять нужно на другой лист.

cheshiki1

#1
=ЕСЛИОШИБКА(ИНДЕКС(№_Кат;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Модель_1);СТРОКА(Модель_1)-1);СТРОКА(Исходник!A1)));"")
формула массива (ctrl+shift+enter)  для остальных поменяйте Модель_1 на соответствующий.

универсальная формула массива =ЕСЛИОШИБКА(ИНДЕКС(№_Кат;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ДВССЫЛ(ПОДСТАВИТЬ(A$1;" ";"_")));СТРОКА(ДВССЫЛ(ПОДСТАВИТЬ(A$1;" ";"_")))-1);СТРОКА(Исходник!A1)));"") просто растягиваем по столбцам.

Natalia

cheshiki1!!!!
Спасибо большое. Начинала я правильно, а потом запуталась. Без Вас точно бы не справилась!!!