Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Выборка из массива за месяц

Автор avgur113, 15.07.2012, 10:30

« назад - далее »

avgur113

Нужно из массива извлечь все данные за месяц без применения макроса.

Шпец Докапыч

Такой вариант:
D2:E44: {=СМЕЩ($A$2;СУММ(--(дата_<ДАТА(2012;6;1)));;СУММ(--(МЕСЯЦ(дата_)=6));2)}
Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли

avgur113

Спасибо.
{СМЕЩ($A$2;СУММ(--(дата_<ДАТА(ГОД(G1);МЕСЯЦ(G1);ДЕНЬ(G1))));;СУММ(--(МЕСЯЦ(дата_)=МЕСЯЦ(G1)));2)}
Так, вроде, работает :)

Шпец Докапыч

Пожалуйста.
Попробуй ещё, вместо ДАТА(ГОД(G1);МЕСЯЦ(G1);ДЕНЬ(G1)), указать просто G1.
Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли

avgur113

Пробовал, на большой таблице выдавал ошибку, я не стал заморачиваться. И еще, #н/д победить не удалось.

Шпец Докапыч

Цитата: avgur113 от 15.07.2012, 14:11
И еще, #н/д победить не удалось.
#Н/Д убирается простым условием:
D2:E44: {=ЕСЛИ(СТРОКА()-1>СУММ(--(МЕСЯЦ(дата_)=МЕСЯЦ(G1)));"";<формула1>)}
Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли

avgur113