Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Суммировать до выполнения определенного условия

Автор Irrrrrok, 16.07.2012, 14:54

« назад - далее »

Irrrrrok

Добрый день. Помогите пожалуйста разобраться. Есть 3 столбца. Код товара, текущая вместимость его места хранения и расход - та величина, которой должна быть равна новая вместимость (устроит приблизительно значение). Для первых 30 товаров нужно рассчитать новую вместимость. Нужно суммировать значения вместимостей товаров (начиная с нижних) до тех пор пока они не будут равны (или немного меньше) расходу самого первого. Пример для товара1 (расход 16800)  новая вместимость будет равна сумме вместимостей товаров 1147-1160, т.е. 16557. Для товара 2 - (расход 8130) - это сумма вместимостей товаров 1139-1146 т.е. 7765. Не могу никак правильно организовать цикл. Помогите пожалуйста  :( :( :(

GWolf

Добрый день!

А цикл то где? И откуда беруться эти значения: "1147-1160"?
Путей к вершине - множество. Этот один из многих!

Шпец Докапыч

Суммирование:
E1160: =1
F1160: =((B1160+F1161)<=СМЕЩ($C$1;E1161;))*F1161+B1160
E1159: =((B1159+F1160)>СМЕЩ($C$1;E1160;))+E1160
(тянем вверх)

Проверка:
E2: =ВПР(A2;$E$500:$F$1160;2;0)
F2: =C2-E2
(тянем вниз)
Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли

Irrrrrok

Отлично работает!!!  :) :) :) то, что нужно огромное-преогромное спасибо!!!