Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Перенос данных из строки в столбцы.

Автор Nurikus, 18.07.2012, 12:24

« назад - далее »

Nurikus

Добрый день!
Есть данные по выручке которые расположены по строке, теперь нужно перенести их вместе с датами в столбец. Можно ли это сделать без VBA и макросов?

Barbarian12

Вариант 1: Скопировать данные, выделить верхнюю левую ячейку, куда будут копировать данные - специальная вставка - указать галочку "транспонировать".

Вариант 2: Выделить диапазон, куда будут копироваться данные и ввести формулу: =ТРАНСП(B3:P4). Формулу вводить как массив, зажав ctrl+shift+enter

Serge 007

=ТРАНСП(B3:P4)
- формула массива

=ИНДЕКС($B$3:$P$4;СТОЛБЕЦ(A1);СТРОКА(A1))
- простая формула
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Nurikus