Формула "Если" в разных диапазонах по значению

Автор Nurikus, 25.07.2012, 13:42

« назад - далее »

Nurikus

Всем привет!
Нужно рассчитать какой номинал сертификата (2000, 5000 или 10 000) подарить гостю в зависимости от его средней маржи. Если маржа до 2000 то 0, если от 2000 до 5000 то 2000, если от 5000 до 10 000 то 5000 если свыше 10000 то 10 000. Как все это рассчитать одной формулой? Нжуна ваша помощь.

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Nurikus

Цитата: Serge 007 от 25.07.2012, 13:51
=ПРОСМОТР(E7;{0;2000;5000;10000})
Не работает, показывает только 2000 сертификат

Serge 007

Цитата: Nurikus от 26.07.2012, 10:07
Не работает...
Если скопировать формулу с форума и вставить в файл - то начнёт работать
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Natalia

А мне всегда проще такие расчеты делать с ВПР!

Serge 007

Можете сократить формулу на четыре знака:

=ВПР(E9;$B$2:$C$5;2;1)
=ВПР(E9;B$2:C$5;2)

Если ссылаться на диапазон ячеек на листе то ПРОСМОТР будет таким:
=ПРОСМОТР(E9;C$2:C$5)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Nurikus

Ок, с функцией просмотр все заработало! Спасибо!
  :D