СЧЁТЕСЛИМН

Автор НовичокExcel, 03.08.2012, 07:29

« назад - далее »

НовичокExcel

имеется лист с данными надо при функции СЧЁТЕСЛИМН как внутри прописать ИЛИ.
пример =СЧЁТЕСЛИМН(ALL!B:B;"Тигра";ALL!C:C;"2011") ИЛИ ALL!C:C;"2012"
подскажите синтаксис ИЛИ внутри СЧЕТЕСЛИМН для данного примера, заранне благодарен

cheshiki1

#1
обязательно СЧЁТЕСЛИМН или можно другую?
напрмер =СУММПРОИЗВ(((ALL!C:C=2011)+(AALL!C:C=2012))*(ALL!B:B="Тигра")*диппазон сумирования)
Если можно другую приложите файл и опишите условие и кстати приведенная формула неправильная. отсутствует диапазон суммирования.

ZORRO2005

=СУММ(СЧЁТЕСЛИМН(ALL!B:B;"Тигра";ALL!C:C;{"2011";"2012"}))
формула массива
Яндекс-деньги: 410011658492153

Poltava

#3
Согласен с cheshiki1 СЧЁТЕСЛИМН не оптимальный выбор. Но если ОЧЕНЬ НУЖНО то можно так
СУММЕСЛИМН(F2:F5;D2:D5;1;E2:E5;"a")+СУММЕСЛИМН(F2:F5;D2:D5;1;E2:E5;"d")
Хотя вариант с СУММПРОИЗВ намного удобней и к тому же будет работать и в 2003 экселе в отличии от СЧЁТЕСЛИМН появившейся лишь в 2007 вот мой вариант записи
=СУММПРОИЗВ(--(D2:D5=1);(E2:E5="d")+(E2:E5="a");F2:F5)
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Serge 007

Цитата: Poltava от 03.08.2012, 11:22
...вариант со СЧЁТЕСЛИМН будет работать в 2003 экселе...
Все функции IFS появились в Excel версий младше 2003.
Соответственно в 2003 работать они не будут
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Poltava

#5
Ой описался  :-[ уже исправил
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

ShAM

Цитата: Poltava от 03.08.2012, 12:48
Ой описплся  :-[ уже исправил
Извините, что Вы сделали?

Poltava

Мартышка к старости слаба глазами стала, еще раз извините
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

НовичокExcel

как в кавычке " " написать ссылку на ячейку чтобы оттуда брались значения, допустим в ячейке "2011";"2012";"2013" и тд

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390