Как посчитать сумму произведений данных из двух массивов

Автор Ярослав, 08.08.2012, 16:59

« назад - далее »

Ярослав

Доброго дня! Выкладываю файл с примером. Даны две таблицы. Первая (лист "Материалы") содержит нормы материалов по изделиям, вторая (лист "Цены мат") содержит прайслист на все материалы. На листе расчет выбирается изделие (ячейка С2). В ячейке С4 должна автоматически считаться стоимость всех материалов на данное изделие (как сумма произведений норм материалов на соответствующую цену для заданного изделия). Буду очень рад помощи знающих людей.

ZORRO2005

#1
=СУММ(Таблица1[[Изделие 1]:[Изделие 5]]*(Таблица1[[#Заголовки];[Изделие 1]:[Изделие 5]]=расчет!C2)*'Цены мат'!D2:D31)
но это при условии что наименования материала на листах "Материалы" и "Цены мат" отсортированы одинаково.
Если порядок не совпадает, то:
=СУММ(Таблица1[[Изделие 1]:[Изделие 5]]*(Таблица1[[#Заголовки];[Изделие 1]:[Изделие 5]]=C2)*ИНДЕКС('Цены мат'!D2:D31;Ч(ИНДЕКС(ПОИСКПОЗ(Таблица1[Наименование материала];'Цены мат'!B2:B31;0);))))
Яндекс-деньги: 410011658492153

Ярослав

Цитата: ZORRO2005 от 08.08.2012, 19:31
=СУММ(Таблица1[[Изделие 1]:[Изделие 5]]*(Таблица1[[#Заголовки];[Изделие 1]:[Изделие 5]]=расчет!C2)*'Цены мат'!D2:D31)
но это при условии что наименования материала на листах "Материалы" и "Цены мат" отсортированы одинаково.
Если порядок не совпадает, то:
=СУММ(Таблица1[[Изделие 1]:[Изделие 5]]*(Таблица1[[#Заголовки];[Изделие 1]:[Изделие 5]]=C2)*ИНДЕКС('Цены мат'!D2:D31;Ч(ИНДЕКС(ПОИСКПОЗ(Таблица1[Наименование материала];'Цены мат'!B2:B31;0);))))

Использовал второй код - выдается #ЗНАЧ! Можете выложить файл?

cheshiki1


ZORRO2005

Яндекс-деньги: 410011658492153

Ярослав

Ага чето я совсем забыл просто скопировал код в строку  :) Спасибо большое все работает.