объединить одинаковые ячейки в один столбец с сохранением привязанных данных

Автор afanasjev88, 09.08.2012, 04:38

« назад - далее »

afanasjev88

Здравствуйте!  

Есть 2 таблицы. В первом столбце каждой таблицы (на рисунке во вложении - столбец "URL") расположены данные, содержание которых в основном совпадает в обеих таблицах, но расположены они в разном порядке.  
У каждой ячейки первого столбца есть привязанная ячейка со значением в той же строке второго столбца (столбец "визиты февраль" и "визиты август" в 1-й и 2-й таблице).

Нужно объединить эти 2 столбца из каждой таблице, чтобы получилась новая таблица из трех столбцов, где данные ячеек из столбцов "визиты" будут стоять в соответствующей ячейке из столбца "URL".

Объясните пожалуйста с учетом того, что я почти не разбираюсь в excel



Poltava

Что вам объединить картинки :) так это в фотошопе. Прикладывайте файл объединим, или вам рассказать как? И еще вопрос в периодичности таких действий если раз в пол года то и ручками можно а если раз в день то уже имеет смысл писать макрос
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

afanasjev88

Конечно лучше рассказать как делать ))  Действие требуется  не сильно часто, но периодически нужно.  Я думал что это можно стандартными средствами экселя сделать.

TimSha

Цитата: afanasjev88 от 09.08.2012, 08:27
Конечно лучше рассказать как делать ))  Действие требуется  не сильно часто, но периодически нужно.  Я думал что это можно стандартными средствами экселя сделать.
В поле "А" на каждом листе вносите наименование месяца, на 3 листе сопи/пастите данные с листов друг  за другом, затем строите сводную... Как вариант для объединения листов -  надстройка: RDBMerge Add-in http://www.rondebruin.nl/merge.htm.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

0mega


afanasjev88, здравствуйте

Из двух таблиц  выбираете и копируете ту, которая больше
на новом Листе делаете копию большой таблицы
С3=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(B3;EntracePages!B$2:B$15;0));"_";(ИНДЕКС(EntracePages!C$2:C$15;ПОИСКПОЗ(B3;EntracePages!B$2:B$15;0))))
D3=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(B3;February!B$2:B$15;0));"_";(ИНДЕКС(February!C$2:C$15;ПОИСКПОЗ(B3;February!B$2:B$15;0))))
Выделяте обе формулы и за нижний правый уголок тяните вниз до конца таблицы

Poltava

ЦитироватьЯ думал что это можно стандартными средствами экселя сделать.
Если под стандартными средствами вы подразумеваете формулы то нет формулы не умеют изменять содержимое ячеек то есть таблицу все равно нужно будет копировать ручками! Если под стандартными средствами подразумевался макрос vba то он это может но писать его без более подробного описания задачи и корректного файла примера просто бесполезное занятие все равно потом переделывать :).
Ну если речь о том чтоб делать все ручками могу предложить такой алгоритм

1) На листе с информацией о новом месяце пишем формулу для проверки существования url в основной база =ПОИСКПОЗ(B2;'Новая таблица'!B:B;0)
В результате действия получаем столбей в котором либо стоит номер позиции url в основной базе либо #Н/Д что означает что url в базе не найден и его туда нужно добавить.
2) Устанавливаем на полученный столбец _автофильтр_ и отображаем только значения   #Н/Д в результате получаем таблицу состоящую только из отсутствующих в базе значений. Выделяем ее и копируем в конец основной базы.
3) Для вставки значения из колонки "Визиты" можно использовать формулу 0mega либо скажем такую =ЕСЛИ(ЕНД(ВПР(B3;EntracePages!B:E;2;ЛОЖЬ));;ВПР(B3;EntracePages!B:E;2;ЛОЖЬ)) Результат готовая таблица с сохраненной ссылочностью то есть при изменении значения визитов в исходной таблице оно измениться в основной. Если такая функция не требуется то тогда выполняем действие 4
4) Выделяем получившуюся колонку со значениями визитов нажимаем скопировать затем клацаем ПКМ выбираем специальная вставка и далее значения. В результате готовая таблица никак не связанная с исходной
В аттаче примерчик с формулами
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.