Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

как добавить пробел

Автор Serg, 28.08.2012, 11:28

« назад - далее »

Serg

Добрый день
Есть табл. данных в которой необходимо добавить пробел после цифр
в файле пример
Пример 22шт 80гр в результате должно быть 22 шт - одном столбце и соотв. 80 гр в следующем

__Nadya__


Serge 007

Мой вариант:
=ЕСЛИ(ЕЧИСЛО(ПОИСК("шт";A2));ЛЕВБ(A2;НАЙТИ("шт";A2)-1)&" шт";"")
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЕСЛИ(B2="";A2;ПОДСТАВИТЬ(A2;ПОДСТАВИТЬ(B2;" ";);)));"гр";" гр");"кг";" кг")
=B2&C2

ЗЫ Работает в любой версии Excel
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

И мой
2003/2007/2010
=ЕСЛИ(ЕЧИСЛО(ПОИСК("ш";A2));ПСТР(A2;1;ПОИСК("ш";A2)-1)&" шт";"")
=ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК("ш";A2));ПСТР(A2;ПОИСК("ш";A2)+3;9);A2);ПРАВСИМВ(A2;2);" "&ПРАВСИМВ(A2;2))
2007/2010
=ЕСЛИОШИБКА(ПСТР(A2;1;ПОИСК("ш";A2)-1)&" шт";"")
=ПОДСТАВИТЬ(ЕСЛИОШИБКА(ПСТР(A2;ПОИСК("ш";A2)+3;9);A2);ПРАВСИМВ(A2;2);" "&ПРАВСИМВ(A2;2))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

NooBasTiK

так можно просто заменить через Ctrl+H "шт" на " шт" и потом уже делить по столбцам.

Serg

ОГРОМНОЕ СПАСИБО!!!