Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Помогите найти среднюю температуру за сутки (файл внутри)

Автор star282, 29.08.2012, 10:34

« назад - далее »

star282

Товарищи приветсятвую! Нужна помощь глубокая...
Есть таблица за несколько лет.
Каждые сутки помечены датой и временем съема характеристик (температура, давление, влажность итд)
Показания снимаются в суткки несколько раз 6-7 раз.
Применить формулу не смог, так как количество дней в месяце, количество съемов в день, разное... =(
ВОПРОС как посчитать среднюю температуру за сутки? Если она снималась в зависимости от настроения гидрометцентра, то 6 то 8 раз в сутки, т.е. нет в таблице переодичности.  

_Boroda_

Если 6-8 раз в сутки, то 15 строк точно должно хватить
=ЕСЛИ(ДЕНЬ(B8)=ДЕНЬ(СУММ(B7));"";СРЗНАЧ(ЕСЛИ(ДЕНЬ(B8:B22)=ДЕНЬ(B8);C8:C22)))
формула массива
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

star282

Скажите а концепция и логика вашей формулы какая? Т.е. что в общем заложено в формулу, если ине трудно? А я сам попробую подробнее тогда вашу формулу разобрать (дешифровывать нравиться) в дальнейшем пригодиться.

ZORRO2005

Яндекс-деньги: 410011658492153

star282


ZORRO2005

#5
Цитата: star282 от 29.08.2012, 11:12
Цитата: ZORRO2005 от 29.08.2012, 11:10
_Boroda_,
СУММ(B7) - красиво!
Это не сарказм? :) Корректно?
Все четко, не волнуйтесь.
На его погоны посмотрите.
Симметрию ему сделайте (по 170). ;D
Яндекс-деньги: 410011658492153

_Boroda_

Цитата: ZORRO2005 от 29.08.2012, 11:10,
СУММ(B7) - красиво!
...
но Ч(B7) короче.
Согласен. Как-то я эту Ч редко использую, поэтому и вспоминаю про нее только в экстренных случаях.
Цитата: star282 от 29.08.2012, 11:06
Скажите а концепция и логика вашей формулы какая? Т.е. что в общем заложено в формулу, если ине трудно? А я сам попробую подробнее тогда вашу формулу разобрать (дешифровывать нравиться) в дальнейшем пригодиться.
Поехали
=ЕСЛИ(ДЕНЬ(B8)=ДЕНЬ(Ч(B7));"";СРЗНАЧ(ЕСЛИ(ДЕНЬ(B8:B22)=ДЕНЬ(B8);C8:C22)))
1. ЕСЛИ(ДЕНЬ(B8)=ДЕНЬ(Ч(B7));""...
выводим среднее только в том случае, когда в столбце В меняется день (то есть в первой строке каждого дня) Ч(B7) написано для того, чтобы можно было самую первую строку таблицы сравнить с шапкой (функция ДЕНЬ от текста дает ошибку, а функция ДЕНЬ от нуля дает ноль, а Ч(что-нибудь) всегда даст само число, если это число или дата и 0, если это текст, а в шапке у нас как раз текст, значит, получится ДЕНЬ(31/12)=ДЕНЬ(0) – ЛОЖЬ, следовательно, переходим ко второй части формулы, а если дни совпадают, то пустая строка ("")
СРЗНАЧ(ЕСЛИ(ДЕНЬ(B8:B22)=ДЕНЬ(B8);C8:C22))
2. ДЕНЬ(B8:B22)=ДЕНЬ(B8) даст нам массив из 15-и ИСТИНА и ЛОЖЬ. ИСТИНА тогда, когда дни в массиве В8:В22 совпадают с днем в В8 и ЛОЖЬ – когда не совпадают
3. ЕСЛИ(ДЕНЬ(B8:B22)=ДЕНЬ(B8);C8:C22) когда ИСТИНА в п.2, (дни совпадают с нужным нам), то берем соответствующее значение из столбца С, а когда ЛОЖЬ – то так эту ЛОЖЬ и оставляем (когда у функции ЕСЛИ нет второго аргумента, то вместо него автоматом ставится ЛОЖЬ)
СРЗНАЧ(ЕСЛИ(ДЕНЬ(B8:B22)=ДЕНЬ(B8);C8:C22)) от массива из чисел и любого текста (а ЛОЖЬ – это текст) считает только числа. Что нам, собственно, и нужно было.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

star282

 я имею сейчас такое выражение лица  :o :'(  :-X  :-\
а вы супермэн!

star282

Вот тут человек мне на примере сводной таблицы сделал концепт, только с использованием сводной таблицы.
Скажите как добился он обьединения 8-ми ячеек (за 1 декабря) в одну строку 1.дек
и округления ср.температуры?
Я не вижу в уже сводной таблице никаких доп.формул =( сам он на связь не выходит.

Serge 007

А зачем там доп. формулы?
Это обычная сводная (Данные - сводная таблица для 2003 или Вставка - сводная таблица для младших версий), она так работает

А среднее выбрано для поля вручную, смотрите его название Среднее по полю T градусы Цельсия
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

star282

Да, вчера с нуля разбирался со сводными таблицами...
Добился нужного результата, но методом научного тыка =( "перетащите сюда строки...ряда..." ой мама! )))