Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

смена формул в зависимости от значения в соседней ячейке

Автор les-nik77, 31.08.2012, 19:34

« назад - далее »

les-nik77

Как задать определенную формулу, в зависимости от того какое значение в соседней ячейке?

_Boroda_

можно так:
=ВЫБОР(ДЛСТР(E2);;F2*D2;F2;;F2*D2*B2;F2*D2*C2*B2)
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

les-nik77

Спасибо, вы настоящий кудесник (без шуток). Воистину, Excel безграничен...

Pelena

Цитата: les-nik77 от 31.08.2012, 21:07
Спасибо, вы настоящий кудесник (без шуток). Воистину, Excel безграничен...
ОФФ:

из Энциклопедии чудес, загадок и тайн
 
"КУДЕСНИК - колдун, маг, действующий и руководствующийся запрещенными или
непонятными методами с способами; творящий чудеса НЕобщепринятым среди
колдунов способом. Слова "чудесник" и "кудесник" имеют общую природу, разница лишь в том, что согласно словарю Даля,
"чудо - всякое явление, которое мы не умеем объяснить" , а "кудеса - это
чудеса, совершаемые посредством нечистой силы" (там же). Но ведь и
"нечистая сила" - это тоже чудо, действие которой до сих пор не объяснено
наукой!"

Думаю, что _Boroda_ всё-таки белый маг :)

Roozevelt

Добрый день. Я новичок в экселе. Может я задания не понял, но у меня такой вариант:
=ЕСЛИ(E2="м.куб.";B2*C2*D2*F2;ЕСЛИ(E2="м.кв.";B2*D2*F2;ЕСЛИ(E2="м.";D2*F2;F2)))

Poltava

Ваш вариант тоже будет работать причем он более универсальный но ув. _Boroda_  заметив одну уникальную особенность задачи смог ее использовать для решения. Его формула значительно короче и проще.
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.