Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Шаг смещения переменных в формулах при копировании

Автор Aglasis, 05.09.2012, 12:01

« назад - далее »

Aglasis

Доброго времени суток! Столкнулся со следующей проблеммой и очень надеюсь на Вашу помощь :)
Книга "Квитанции" должна заполнятся данными взятыми из таблицы в книге "Ввод", каждый лист должен соответствовать следующей части таблицы (высота каждой части таблицы = 6). На первой странице так и есть, но при копировании ссылки смещаются на 56 позиций (количество строк в листе). Как установить смещение равным 6?
Квитанции!B3 =ЕСЛИ(Ввод!$C8="";"";СЦЕПИТЬ(Ввод!$C8; "."; Ввод!$B8)), а Квитанции!B59 =ЕСЛИ(Ввод!$C64="";"";СЦЕПИТЬ(Ввод!$C64; "."; Ввод!$B64)), должно чтобы было =ЕСЛИ(Ввод!$C14="";"";СЦЕПИТЬ(Ввод!$C14; "."; Ввод!$B14)), в следующих печатных листах прирост должен быть также равен 6, а не 56.
(файл с примером прикрепил ниже).

Автозамена не вариант.

cheshiki1

#1
пробуйте
=ИНДЕКС(Ввод!$C$1:$C$103;6*СЧЁТЕСЛИ($A$1:$A3;$A3)+2+СТОЛБЕЦ(A1)-1)&"."&ИНДЕКС(Ввод!$B$1:$B$103;6*СЧЁТЕСЛИ($A$1:$A3;$A3)+2+СТОЛБЕЦ(A1)-1)
если сами допишите.

я так понимаю вы потом эти квитанции печатать будете.
не проще создать одну квитанцию-шаблон, на первом листе поставить например "Х" напротив тех данные которые должны попасть в квитанцию для печати.
И распечатать все помеченные данные автоматически по очереди подставляя их в шаблон квитанции (макросом).