Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Помогите разобраться с функцией "И"

Автор ardent, 08.09.2012, 02:18

« назад - далее »

ardent

вообщем задача в следующем:
В одном столбце есть тексты в ячейках, в другой хочу собрать такие в которых содержится два заданные слова, причем этим ячейкам присвоить значения "1" или же "" (пусто).
Например:
столбец А                 столбец В
мама мыла раму           1
папа мыл раму             (пусто)
саша мыла раму           1
мама мыла папу           (пусто)

т.е. в столбце В те у которых содежится два слова "мыла" И "раму"
додумался до подобного, но не работает: =ЕСЛИ(ИЛИ(И(ЕСЛИОШИБКА(НАЙТИ("мыла";"раму";A1);0)>0);1;"")

DV68

#1
Результат формулы или 1 или 0:
=СЧЁТ(НАЙТИ("мыла";A1)*НАЙТИ("раму";A1))
или так
=ЕСЛИОШИБКА(--И(НАЙТИ("мыла";A1);НАЙТИ("раму";A1));"")

ZORRO2005

ИСТИНА или ЛОЖЬ:
=СЧЁТ(НАЙТИ({"мыла";"раму"};A1))=2
Яндекс-деньги: 410011658492153

ardent