Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Помогите найти похожие значения

Автор frankie, 09.09.2012, 03:30

« назад - далее »

frankie

Доброго времени суток.
Возникла такая проблема...
Есть огромное количество кодов, допустим товар FFFFFFFFFFF=FFFFFFFFFFA=FFFFFFFFFAF=FFFFFFFFAFА. т.е. если код 11-значный, то как сгрупировать эти коды по группам, таким образом, что 7 и больше значений были одинаковыми, а 4-3-2 - разные. И эти значения 4, 3 или 2 могут меняться в любых позициях.
Вообщем я в недоумении...




Poltava

Может кто то и понял но я так и не смог понять что вам нужно. Если бы к примеру приложили хотябы пояснение из 10-15 строчек того как должно быть а не только то что есть было бы лучше.
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

frankie

Примерно так должно выглядеть.

ZORRO2005

Стало намного "понятнее".
Может такой вариант нужен (см. вложение)
Яндекс-деньги: 410011658492153

cheshiki1

формула массива для доп. столбца
=ЕСЛИ(И(СУММ(--(ЕСЛИ(ПСТР(A2;СТРОКА($A$1:$A$11);1)="F";1;0)))>=7;СЧЁТЕСЛИ($A$1:A2;A2)=1);МАКС($B$1:B1)+1;"")
для списка =ИНДЕКС($A$1:$A$21190;ПОИСКПОЗ(СТРОКА(C1);$B$1:$B$21190;0))