копирывание на другой лист с изменением данных (ссылок) автоматичеки

Автор salien, 10.09.2012, 11:47

« назад - далее »

salien

Добрый день.
Нужна помощь.Копирую лист Вересень 2012(факт) (в нем ссылка на лист Серпень (факт)),на новый лист Жовтень(факт) и в нем остается ссылка на Серпень(факт)к примеру ячейка AL17, а нужно что бы была ссылка на Вересень(факт).
Может можно както это привязать к значению в ячейке N6? она вводится вручную на каждый месяц.
Или какой нибуть еще способ.
Также в Вересень(перераб) есть формула
=ЕСЛИ('Вересень 2012 (факт) '!X21="А";"";ЕСЛИ('Вересень 2012 (факт) '!X21="";"";ЕСЛИ('Вересень 2012 (факт) '!X21=8;"";ЕСЛИ('Вересень 2012 (факт) '!X21<8;'Вересень 2012 (факт) '!X21-8;ЕСЛИ('Вересень 2012 (факт) '!X21="Хв";"";ЕСЛИ('Вересень 2012 (факт) '!X21="В";"";ЕСЛИ('Вересень 2012 (факт) '!X21>8;'Вересень 2012 (факт) '!X21-8;"")))))))
и везде менять на Жовтень не очень удобно

chombi

попробуйте ctri+F заменить.
Одной операцией меняете весь Вересень на Жовтень.

salien

Цитата: chombi от 10.09.2012, 12:15
попробуйте ctri+F заменить.
Одной операцией меняете весь Вересень на Жовтень.


Спасибо, прийдется делать так. Хотелось конечно, что бы менялась формула автоматом при копирывании

_Boroda_

Для начала поменяйте Вашего монстра из первого поста на вот так:
=ЕСЛИ(ЕЧИСЛО(1/(('Вересень 2012 (факт)'!E17&"")-8));'Вересень 2012 (факт)'!E17-8;"")
или даже
=ЕСЛИ(ЕЧИСЛО(1/((ДВССЫЛ("'"&$N$6&" "&$R$6&" (факт)'!"&ЯЧЕЙКА("адрес";E17))&"")-8));ДВССЫЛ("'"&$N$6&" "&$R$6&" (факт)'!"&ЯЧЕЙКА("адрес";E17))-8;"")
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

salien

Цитата: _Boroda_ от 10.09.2012, 13:12
Для начала поменяйте Вашего монстра из первого поста на вот так:
=ЕСЛИ(ЕЧИСЛО(1/(('Вересень 2012 (факт)'!E17&"")-8));'Вересень 2012 (факт)'!E17-8;"")
или даже
=ЕСЛИ(ЕЧИСЛО(1/((ДВССЫЛ("'"&$N$6&" "&$R$6&" (факт)'!"&ЯЧЕЙКА("адрес";E17))&"")-8));ДВССЫЛ("'"&$N$6&" "&$R$6&" (факт)'!"&ЯЧЕЙКА("адрес";E17))-8;"")


Спасибо!

salien

Цитата: _Boroda_ от 10.09.2012, 13:12
Для начала поменяйте Вашего монстра из первого поста на вот так:
=ЕСЛИ(ЕЧИСЛО(1/(('Вересень 2012 (факт)'!E17&"")-8));'Вересень 2012 (факт)'!E17-8;"")
или даже
=ЕСЛИ(ЕЧИСЛО(1/((ДВССЫЛ("'"&$N$6&" "&$R$6&" (факт)'!"&ЯЧЕЙКА("адрес";E17))&"")-8));ДВССЫЛ("'"&$N$6&" "&$R$6&" (факт)'!"&ЯЧЕЙКА("адрес";E17))-8;"")



Если можно распишите  ДВССЫЛ("'"&$N$6&" "&$R$6&" (факт)'!"&ЯЧЕЙКА("адрес";AB21))

_Boroda_

Вечером, хорошо? Сейчас занят - работа.
Объяснялка внутри файла.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

salien

Цитата: _Boroda_ от 11.09.2012, 13:38
Вечером, хорошо? Сейчас занят - работа.
Объяснялка внутри файла.


СПАСИБО!!!

salien

Добрый день! Если помните эту тему, Вы давали ответ, который подошел, но возникла проблема: если в фактическом табеле выпадает суббота, а она рабочая(к примеру 8), то в переработке выдает "пусто", а надо 8