Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Сравнить ячейку из стольбца по двум столбцам последавательно

Автор Alvik35, 16.09.2012, 11:54

« назад - далее »

Alvik35

Добрый день!
Нужна помощь. Задача: Сравнить ячейку из стольбца сначала с ячейками из этого же столбца, в случае совпадения сравнить ячейку слева (соседний столбец) с ячейками уже второго столбца, и если совпадение - напротив вывод результата. Пример: Ячейка D1 совпадает с D6 и D21. Ячейке D6 соответствует "Апельсин", не совпадает с ячейкой напротив D1 "Яблоко". А ячейке D21 соответствует "Яблоко", сопадает с ячейкой напротив D1, вывод результатта в ячейки E1,E2,E3 в виде " 21.Яблоко.04.08.12", либо просто результат  в виде количества совпадений.
Спасибо.

_Boroda_

=СУММПРОИЗВ(--(D$1:D$35&B$1:B$35=D1&B1))-1
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Alvik35

Спасибо большое. Только второе условие не работает. См. пример.2: Ячейка D1 равна D6 и D25. B6 (Апельсин) не совпадает с В1 (Яблоко) но совпадает с в25 (Апельсин). Итог должен быть равен 1, а выдает 0. Возможно ли выполнить второе условие.

_Boroda_

Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995