Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

вычитание дат и времени

Автор srp, 03.10.2012, 19:12

« назад - далее »

srp

Господа, добрый вечер.
есть четыре поля: Дата Начала, Время Начала, Дата Окончания, Время Окончания.
Необходимо в пятом поле получить длительность (Дата/Время Окончания - Дата/Время Начала)
Помогите, пожал.

MCH


ВЕВ

Помогите пож. сделать формулу.
Мастер смены вводит в одну ячейку время начала работы, в другую - время окончания работы.
В таком формате: ч,мм. Т.е. 23,25 - это 23 часа 25 мин. Часы и минуты отделяет запятой (это важно, так удобнее).
Необходимо в отдельной ячейке посчитать разность, т.е. продолжительность выполнения работ и именно в минутах.

cheshiki1

=ЕСЛИ(B1>A1;ЦЕЛОЕ(B1-A1)*60+ОСТАТ(B1-A1;1)*100;ЦЕЛОЕ(24-A1)*60+(0,6-ОСТАТ(A1;1))*100+ЦЕЛОЕ(B1)*60+ОСТАТ(B1;1)*100)

ВЕВ

Круто! Спасибо! А формат ячеек, как я понял может быть числовой?

ВЕВ

14,55    15,20        формула считает 65, а не 25???

cheshiki1

=ЕСЛИ(B1>A1;(ЦЕЛОЕ(B1)+ОСТАТ(B1;1)*100/60-ЦЕЛОЕ(A1)-ОСТАТ(A1;1)*100/60)*60;ЦЕЛОЕ(24-A1)*60+(0,6-ОСТАТ(A1;1))*100+ЦЕЛОЕ(B1)*60+ОСТАТ(B1;1)*100)

zs

арифметика=(((ОТБР(A4)+(A4-ОТБР(A4))/0,6)-(ОТБР(A5)+(A5-ОТБР(A5))/0,6))*60)

ВЕВ

Цитата: zs от 28.08.2013, 16:25
арифметика=(((ОТБР(A4)+(A4-ОТБР(A4))/0,6)-(ОТБР(A5)+(A5-ОТБР(A5))/0,6))*60)
По этой формуле неправильно считает, если время начала 23,30, а окончание работы 7,30

zs

Здравствуйте, ВЕВ! Предыдущая формула не ваш случай (посмотрите на дату поста). Может эта подойдёт
=--ЕСЛИ(ЗНАЧЕН(B1)<=12;(1-ЗАМЕНИТЬ(A1;НАЙТИ(",";A1);1;":"))+ЗАМЕНИТЬ(B1;НАЙТИ(",";B1);1;":");ABS(ЗАМЕНИТЬ(A1;НАЙТИ(",";A1);1;":")-ЗАМЕНИТЬ(B1;НАЙТИ(",";B1);1;":")))*1440

zs

Первоначально текстовый формат

zs

Цитата: ВЕВ от 12.10.2014, 02:01
Цитата: zs от 28.08.2013, 16:25
арифметика=(((ОТБР(A4)+(A4-ОТБР(A4))/0,6)-(ОТБР(A5)+(A5-ОТБР(A5))/0,6))*60)
По этой формуле неправильно считает, если время начала 23,30, а окончание работы 7,30
так вычесть 24 и по этой формуле правильно считает
арифметика=(((ОТБР(A4)+(A4-ОТБР(A4))/0,6)-(ОТБР(A5)+(A5-ОТБР(A5))/0,6))*60)-24
Первоначально числовой формат

zs

Цитата: zs от 12.10.2014, 09:31
(посмотрите на дату поста).
Одна из декларируемых задач форума-активизировать мозговой штурм всех пользователей ;) Так что: Пользователи всех форумов - присоединяйтесь!!!