Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Подстановка переменной в значение ячейки

Автор Briareos, 15.10.2012, 16:57

« назад - далее »

Briareos

Суть такова, требуется по условию рандомно подставлять в ячейку значение одной из n ячеек, основной проблемой стало рандомно выбрать номер ячейки, как это сделать?

Hugo121

=IF(B1=1,C1=INDIRECT("E"&RANDBETWEEN(1,20)),"не указано")
Только что это, зачем это...
webmoney: E265281470651 Z422237915069

Briareos


Hugo121

webmoney: E265281470651 Z422237915069

Briareos

#4
Не работает формула, ошибок не выдает но постоянно "Ложь"

=ЕСЛИ(B1=1;C1=ДВССЫЛ("A"&СЛУЧМЕЖДУ(1;20));не указано)

З.Ы. - Заработало, спс.

=ЕСЛИ(B1=1;ДВССЫЛ("A"&СЛУЧМЕЖДУ(1;20));"Какая то лажа!")

Hugo121

Понажимайте чаще F9 - один раз из 20 возможно будет ИСТИНА (если конечно в C1 будет правильное число) :)
webmoney: E265281470651 Z422237915069

Briareos

А как сделать то же самое только со ссылкой на другой лист?
=ЕСЛИ(H2=ПОИСК(текст;H2;1);ДВССЫЛ('Список значений'!"A"&СЛУЧМЕЖДУ(1;20));"Какая то лажа!")

ShAM

=ЕСЛИ(H2=ПОИСК(текст;H2;1);ДВССЫЛ("'Список значений'!A"&СЛУЧМЕЖДУ(1;20));"Какая то лажа!")

Briareos

#8
Есть условие:
=ЕСЛИ(ПОИСК("Design-60";H2);ДВССЫЛ("'Список значений'!"&"A"&СЛУЧМЕЖДУ(1;63));ЕСЛИ(ПОИСК("Design-70";H2);ДВССЫЛ("'Список значений'!"&"B"&СЛУЧМЕЖДУ(1;24));ЕСЛИ(ПОИСК("GENEO-86";H2);ДВССЫЛ("'Список значений'!"&"C"&СЛУЧМЕЖДУ(1;48));ЕСЛИ(ПОИСК("BriD";H2);ДВССЫЛ("'Список значений'!"&"D"&СЛУЧМЕЖДУ(1;144))))))

Проблема в том что при выполнении первого условия все работает как надо, но если "Design-60" не находит в тексте ячейки, то вываливается ошибка #ЗНАЧ! вместо того чтобы перейти к действию если ЛОЖЬ. Что я делаю не так?

Решение:
=ЕСЛИ(НЕ(ЕОШИБКА(ПОИСК("Design-60";H2)));ДВССЫЛ("'Список значений'!"&"A"&СЛУЧМЕЖДУ(1;63));ЕСЛИ(НЕ(ЕОШИБКА(ПОИСК("Design-70";H2)));ДВССЫЛ("'Список значений'!"&"B"&СЛУЧМЕЖДУ(1;24));ЕСЛИ(НЕ(ЕОШИБКА(ПОИСК("GENEO-86";H2)));ДВССЫЛ("'Список значений'!"&"C"&СЛУЧМЕЖДУ(1;48));ЕСЛИ(НЕ(ЕОШИБКА(ПОИСК("BriD";H2)));ДВССЫЛ("'Список значений'!"&"D"&СЛУЧМЕЖДУ(1;144))))))