Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Выделить условным форматированием имена, которые есть в другом списке

Автор Олег*, 19.10.2012, 17:18

« назад - далее »

Олег*

Имеется два списка: один просто список, а второй "черный". Требуется с помощью формул условного форматирования выделить те имена в первом списке, которые фигурируют в "черном". Подскажите, пожалуйста, как это сделать.

Я тут замучался. Для одной ячейки вроде бы получилось сделать, но как эту формулу распространить на другие ячейки, сообразить не могу.

Предварительная формула получилась вот такая:

=ЕСЛИ(НЕ(ЕСЛИОШИБКА(ПОИСКПОЗ(A2;ЧерныйСписок);"не найдено")="не найдено");ИСТИНА)

"Недоделанный" файл примера прилагаю.

P.S. Вроде бы нашел, как формулу "размножить" на другие ячейки:

https://forum.msexcel.ru/microsoft_excel/uclovnoe_formatirovanie_diapazon_dannyh-t363.0.html;msg1816#msg1816

Но уж больно эта формула неуклюжая получилась, да и не уверен я, что она работать будет как надо. Может быть подскажете более оптимальную формулу под эту задачу?
Муж это единственный зарегенный юзер, а все остальные это хакеры :)

Serge 007

Необходимо выделить диапазон А2:А10 начиная с А2 и ввести в УФ следующую формулу
=ЕЧИСЛО(ПОИСКПОЗ(A2;ЧерныйСписок;))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Prist

Я думаю, что формула должна быть все же такой:
=НЕ(ЕНД((ПОИСКПОЗ(A2;ЧерныйСписок;0))))

Иначе смысл Черного списка теряется. Просто выделяете сначала нужный диапазон ячеек и задаете правила.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
www.excel-vba.ru
Просто СПАСИБО [+оказать+]
Считаешь СПАСИБО мало? Яндекс.Деньги: 41001332272872; WM: R298726502453

_Boroda_

=ЕЧИСЛО(ПОИСКПОЗ(A2;ЧерныйСписок;))или
=НЕ(ЕНД((ПОИСКПОЗ(A2;ЧерныйСписок;0))))
А какая в данном случае разница?

Предложу еще формулу
=СУММ(-(A2=ЧерныйСписок))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Олег*

Serge 007, Prist, _Boroda_

Большое спасибо! Все работает как надо!

На самом деле, как правильно подметил Serge007 , я изначально действовал неправильно, т.е. сначала хотел вставить формулу в одну ячейку, а потом "распространить" ее на весь диапазон.
Муж это единственный зарегенный юзер, а все остальные это хакеры :)

Serge 007

Цитата: Олег* от 19.10.2012, 21:59
...как правильно подметил Serge007 , я изначально действовал неправильно, т.е. сначала хотел вставить формулу в одну ячейку, а потом "распространить" ее на весь диапазон.
Олег, можно и так и так :)

Я написал как я делаю, мне так удобно, но можно и так:
Выделяем ячейку А2 и в УФ пишем формулу, любую из предложенных выше (ещё один вариант: =СЧЁТЕСЛИ(ЧерныйСписок;A2))
Потом копируем ячейку А2, выделяем диапазон в котором надо иметь УФ (в данном случае это А2:А10) - ПКМ -  Спец. вставка - Форматы - ОК
Аналогично можно воспользоваться функцией Формат по образцу ("Метёлка" со вкладки Главная - группа Буфер обмена)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Олег*

Serge 007
Спасибо за подробные объяснения!

Цитата: Serge 007 от 19.10.2012, 23:01
Аналогично можно воспользоваться функцией Формат по образцу ("Метёлка" со вкладки Главная - группа Буфер обмена)

На самом деле, я раньше всегда так и поступал, но здесь меня смутило то, что самостоятельно надо формулу (-ы) вставлять. Обычно-то я интерфейс Экселя использовал для вставки простого условия (больше, меньше, равно... ) в одну ячейку, а потом "метелкой" распространял этот формат на весь диапазан.
Муж это единственный зарегенный юзер, а все остальные это хакеры :)

brosik

Цитата: _Boroda_ от 19.10.2012, 20:10
=ЕЧИСЛО(ПОИСКПОЗ(A2;ЧерныйСписок;))или
=НЕ(ЕНД((ПОИСКПОЗ(A2;ЧерныйСписок;0))))
А какая в данном случае разница?

Предложу еще формулу
=СУММ(-(A2=ЧерныйСписок))

Подскажите, это работает до тех пор пока исходный список содержит любое значение идентичное значению в черном списке. как быть если в исходном списке у нас не "петя" а "петя иванов"?

Serge 007

Цитата: brosik от 06.02.2016, 19:42...как быть если в исходном списке у нас не "петя" а "петя иванов"?
Создавайте новую тему, т.к. это уже совершенно иная задача чем задача топика
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

zs

условное_форматирование
=ЕОШИБКА(ПОИСКПОЗ(B5;$A$2:$A$16;0))
Формат отличный от стандартного, по желанию пользователя)