Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Ссылка на ячейку, которая меняется от другой ячейки

Автор Виктор Зарецкий, 04.11.2012, 23:57

« назад - далее »

Виктор Зарецкий

По поиску не нашел... Никак не могу сделать ссылку на ячейку зависящую от значения в другой ячейке.... интуитивно это так: =R"R2C2"C1 ,т.е. я хочу получить ссылку =R2C1, если в R2C2 стоит 2... или =R3C1, если в R2C2 стоит 3
Интуитивный вариант выдает ошибку... как мне правильно записать? Заранее спасибо!

Serge 007

Написано ПОЧТИ правильно :)
Только надо использовать
=ЕСЛИ(R2C2=2;R2C1;ЕСЛИ(R2C2=3;R3C1))

ЗЫ Если не получается - прикладывайте файл
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

Может, Вы про это
=ДВССЫЛ("R"&R2C2&"C1";0)
или так еще
=СМЕЩ(R1C1;R2C2-1;)
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Виктор Зарецкий

Спасибо! Работает для задачи, что я описал: =ДВССЫЛ("R"&R2C2&"C1";0)
Но по аналогии не получилось привязать к моей конкретной задаче(
Вот что я записываю....   человек легко поймет, а excel никак.....
=МИН("R"&R10C10&"C7";"R"&R11C10&"C7")
И при значениях в R10C10 = 47, а в R11C10 = 263 я хочу получить =МИН(R47C7;R263C7)
Как мне записать это по-EXCELевски: =МИН("R"&R10C10&"C7";"R"&R11C10&"C7")

ShAM

#4
Так надо добавить ДВССЫЛ к обоим аргументам у МИН.
Вы бы файл приложили, как было написано еще 8 часов назад, и что хотите получить. Может проще можно сделать.

Виктор Зарецкий

Спасибо! Прикрепил файл...  В формулу красной ячейки мне приходится вводить значения из зеленых ячеек вручную...  Хочу автоматизировать! В файле все будет понятно...

ShAM

#6
Вроде уже ответил:
=МИН(ДВССЫЛ("R"&R10C10&"C7";);ДВССЫЛ("R"&R11C10&"C7";))

Виктор Зарецкий

Не так...   Тут он выдает минимальное значение из двух ячеек....   а мне нужно из диапазона :-[

ShAM

Поменяйте между аргументами ";" на ":".
=МИН(ДВССЫЛ("R"&R10C10&"C7";):ДВССЫЛ("R"&R11C10&"C7";))

Виктор Зарецкий


cheshiki1

еще можно так
=МИН(ИНДЕКС(G:G;$J$10):ИНДЕКС(G:G;$J$11))
или
=МИН(СМЕЩ($G$1;$J$10-1;;$J$11-$J$10;1))