Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Чему равна пустая ячейка?

Автор 0mega, 19.11.2012, 09:27

« назад - далее »

0mega

Доброго времени суток.
Всегда считал что пустая ячейка -это ноль.
Если написать формулу =2*А1, то в ответе будет 0
диаметрально противоположный результат получается если:
=МИН(F1;99)
В этом случае машина выбирает 99
Если пустую ячейку приравнять к другой пустой ячейке , тогда результат "разворачивается "

Чему равна пустая ячейка?

_Boroda_

При выполнении арифметических действий ПЯ преобразуется в ноль, при выполнении операций сравнения функциями агрегирования (например, см. справку для МАКС или МИН) - это текст
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

kuklp

Не надо путать 0 и пустое значение. Пустая ячейка равна именно пустому значению. Эксель по своему усмотрению неявно преобразовывает данные, но всегда лучше явно преобразовать данные в нужный тип. Это часто избавляет от неожиданных результатов:-)
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

_Boroda_

Цитата: KuklP от 19.11.2012, 09:55всегда лучше явно преобразовать данные в нужный тип. Это часто избавляет от неожиданных результатов:-)
Вот-вот, абсолютно согласен. Уж про неожиданные результаты у меня каждую неделю приколы на работе у сотрудников. И вопли типа "А почему этот гад не считает так, как я хочу?"
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

0mega

 Александр, здравствуй.

Цитата: _Boroda_ от 19.11.2012, 09:54
(... для МАКС или МИН) - это текст

Меня все время "нервировала " буква "ё" с ее весовым значением
Теперь вот добавилась еще и пустая ячейка.
Все буквы имеют свой вес , который адекватен цифровому коду.
но по непонятной причине цифры "легче" не только  букв (что соответствует цифровому коду), но и знаков препинания тоже  ?! ( хотя амперсанд находится на 10 позиций выше чем 0 )
Получается что в этом ранге пустая ячейка  - самая "тяжелая" ?!


Serge 007

Правила сортировки по умолчанию:

Excel сортирует данные по особым правилам сортировки. При сортировке по возрастанию Excel использует следующий порядок. (При сортировке по убыванию этот порядок обратный за исключением пустых ячеек, которые всегда располагаются последними.)

Числа - Excel сортировка чисел от наименьшего отрицательного до наибольшего положительного числа.

Текст - Excel сортирует алфавитно-цифровой текст слева направо, знак за знаком.
Текст, в том числе содержащий числа, сортируется в следующем порядке:
0 1 2 3 4 5 6 7 8 9 (пробел) ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J K L M N O P Q R S T U V W X Y Z А Б В Г Д Е Ё Ж З И Й К Л М Н О П Р С Т У Ф Х Ц Ч Ш Щ Ъ Ы Ь Э Ю Я
Апострофы (') и дефисы (-) игнорируются с единственным исключением: если две строки текста одинаковы, не считая дефиса, текст с дефисом ставится в конец.

Логические значения - значение FALSE идёт до TRUE.

Значения ошибок - Excel обрабатывает все значения ошибки, как равнозначные.

Пустые ячейки - Excel всегда помещает пробелы в конце списка.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

0mega

Цитата: Serge 007 от 19.11.2012, 14:44
сортируется в следующем порядке: 0 1 2 3 4 5 6 7 8 9 (пробел) ! " # $ ...

Пустые ячейки - Excel всегда помещает пробелы в конце списка.
Противоречие, однако

Serge 007

Цитата: 0mega от 19.11.2012, 18:12
Противоречие, однако
Не противоречие, а хреновый перевод Microsoft :)
Если в ячейке есть пробел, то она уже не пустая :)

Правильно читать так:
Пустые ячейки - Excel всегда помещает пустые ячейки в конце списка.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

0mega


edmar07

#9
тоже нужно было действия с пустой ячейкой и вот что оказалось...

пустая ячейка больше (тяжелее) цифр, но меньше (легче) букв  (и то относительно)

тут примерчик, кстати, може кто прояснит в чем "соль" ;)


чуть почитал... и разобрался)))

0mega

#10
edmar07, здравствуйте

первая ошибка заключается в том что неправильно записана формула в ячейке В7
=ЕСЛИ(И(A7<>$A18>=$B$3);A7-$D$3;"")
Двойное неравенство нельзя так записывать
Правильно так:
=ЕСЛИ(И(A7<>$A18;A7>=$B$3);A7-$D$3;"")

edmar07

Цитата: 0mega от 20.03.2013, 21:30
edmar07, здравствуйте

первая ошибка заключается в том что неправильно записана формула в ячейке В7
=ЕСЛИ(И(A7<>$A18>=$B$3);A7-$D$3;"")
Двойное неравенство нельзя так записывать
=ЕСЛИ(И(A7<>$A18;A7>=$B$3);A7-$D$3;"")

В7 - эт я не доглядел, точнее пробы всякие были и не доделал, сам прикол начинается в ячейках G7 и H7 когда начинаються сравнивания с пусто и как следствие вычитания из него, так как оно опять подходит под истину;)

0mega

Цитата: edmar07 от 20.03.2013, 21:37
сам прикол начинается в ячейках G7 и H7 когда начинаються сравнивания с пусто и как следствие вычитания из него, так как оно опять подходит под истину;)

Именно этот вопрос и задавался в стартовом топике

Цитата: 0mega от 19.11.2012, 09:27

Всегда считал что пустая ячейка -это ноль.
Если написать формулу =2*А1, то в ответе будет 0
диаметрально противоположный результат получается если:
=МИН(F1;99)
В этом случае машина выбирает 99
Если пустую ячейку приравнять к другой пустой ячейке , тогда результат "разворачивается "
И Александр объяснил эту позицию
Цитата: _Boroda_ от 19.11.2012, 09:54
При выполнении арифметических действий ПЯ преобразуется в ноль, при выполнении операций сравнения функциями агрегирования (например, см. справку для МАКС или МИН) - это текст





zs

"неуловимые" символы ;)

0mega

еще один косяк:
Н22="">0

Дело в том что "" - это НЕ ПУСТО ! это ячейка занятфя значением ""
Правильно будет так:
Н22=AZ9999>0