Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

выборка

Автор igroker, 21.11.2012, 16:08

« назад - далее »

igroker

Нужен совет
есть 2 столбца  где разное количество  чисел  надо  выбрать  просто первые шесть цифр    отличные от нуля   и поместить их таблицу  по порядку попаданию в таблицу  сверху вниз
каждый день   в столбце появляется новая  строчка сверху   и там возможно появляение  новой цифры или нуля и это тоже нужно учесть  в таблице
пример  прилагаю  к  этой теме

Serge 007

Мало что понял из описания...

Как понял:
=НАИБОЛЬШИЙ(ДВССЫЛ("A2:B100");СТРОКА())
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

igroker

 c вашей формулы она выбирает найбольш ую а мне  нужно  чтобы она  выбирала   первые шесть  цифр подряд  отличные от нуля
вот ряд  допустим  0 0 3 0 0  5  8 0  9  2  0 0 5  1 0 4 0 7
чтобы результат получился такой   3  5  8  9  2  5

igroker

правильнее сказать  наверно что это будет сортировка  первые подряд  6 цифр  отличные от нуля

Serge 007

Тогда так:
=ИНДЕКС($A1:$R1;;НАИМЕНЬШИЙ(ЕСЛИ($A1:R$1>0;СТОЛБЕЦ($A1:R$1));СТОЛБЕЦ(A1)))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

igroker

спасибо большое  за ответ
если    можно  чтобы компатнее было  убирать нули с ряда написать формулу  и превратить этот ряд
0 0 3 0 0  5  8 0  9  2  0 0 5  1 0 4 0 7
в  такой ряд   3 5 8 9 2 5 1 4 7
а  с него уже по вашей формуле выбирать первые 6  чисел

Serge 007

Цитата: igroker от 21.11.2012, 18:03
если    можно убирать нули с ряда написать формулу  и превратить этот ряд
0 0 3 0 0  5  8 0  9  2  0 0 5  1 0 4 0 7
в  такой ряд   3 5 8 9 2 5 1 4 7
Нет, нельзя
Формулы ничего не могут удалить/убрать/изменить

Цитата: igroker от 21.11.2012, 18:03
по вашей формуле выбирать первые 6  чисел
Это уже реализовано, см. файл-пример выше
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

igroker

еще раз спасибо  за формулу

igroker

а  можно формулу  подогнать если  написаны не  в строчку а в   столбец
0                     и  результат тоже в столбец   3
0
3                                                                5
0
0                                                                 8
5
0                                                                 9                               
8                                                                 2
0                                                                  1
9
2

igroker

колонка цифр может идти и без нулей просто пустые   строчки

Serge 007

Цитата: igroker от 21.11.2012, 23:06
можно формулу  подогнать если  написаны не  в строчку а в   столбец ?
Можно
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

igroker

cпасибо большое