Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

сколько разных значений используется

Автор goblonde, 18.12.2012, 19:22

« назад - далее »

goblonde

Добрый!
Как можно подсчитать сколько различных значений имеется в каждом столбце таблицы? То есть, повторяющиеся значения учитывать только 1 раз.

Спасибо

cheshiki1

формула массива
=СУММ(--(ЕСЛИ(ЕНД(ПОИСКПОЗ(A2:A9;A2:A9;0));0;ПОИСКПОЗ(A2:A9;A2:A9;0))=СТРОКА(A1:A8)))

goblonde

Спасибо!
По ходу возник вопросик.. А как можно по быстрому формулу на русском языке транслировать в английскую версию Excel?

goblonde

А можно в файле посмотреть? У меня чё-то не работает.. Даже без третьей скобки в конце :(

goblonde

=SUM(--IF(ISNA(MATCH(A2:A9,A2:A9,0)),0,MATCH(A2:A9,A2:A9,0)=ROW(A1:A8)))
Вот сейчас работает!!!
Спасибо

Poltava

ЦитироватьА как можно по быстрому формулу на русском языке транслировать в английскую версию Excel
1) Нажали кнопочку записать макрос
2) Выделили ячейку с формулой и нажали F2 а затем ентер
3) Остановили запись макроса
4) Alt+F11 и просматриваем записанный макрос в нем будет формула переведенная на английски язык.
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

goblonde

Спасибо за советы. Хоть я и не сторонница чуть-что – сразу прибегать к макросам, в данной случае это всё же реальный выход из ситуации, когда формулы выложены здесь в виде текста, а не в файлe..

kuklp

Откуда такая нелюбовь к макросам?  Они гораздо гибче формул и возможностей у них го-ораздо больше.
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

goblonde

каждый раз нужно обращаться к сисадмину, чтобы позволил снизить степень безопасности... А у него делов поважнее хватает..