Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

не могу разобраться с применением функции ВПР совместно с ИНДЕКС

Автор boga47, 19.12.2012, 16:31

« назад - далее »

boga47

Здравствуйте. Прошу помощи.
Задача.
Создать в EXCEL электронную форму, где с помощью элементов управления, можно подобрать конфигурацию компьютера. Форма на одном листе – Конфигурация. Исходные данные на другом листе – Прайс.
Проблема. При попытке получить на листе Конфигурация цену из листа  - Прайс с помощью функций ВПР и ИНДЕКС идет ошибка  #ЗНАЧ.
Пример функции =ВПР(ИНДЕКС(Память;$B$8);Прайс!B2:C7;2;ЛОЖЬ)
Образец книги в приложении. Статьи и топики читал. Не помогло.

Poltava

Просто нужно быть чуть чуть внимательнее! У вас Раскрывающиеся списки возвращают результат в ячейки A9 и A15 нарушая при этом работу чекбокса и радиокнопок а индекс берет значение из ячейки B8 и B14 которые всегда получаются пустыми! это и есть причина ошибки возвращаемой функцией индекс! свяжите с правильными ячейками комбо боксы и все заработает!
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

boga47

ОГРОМНОЕ СПАСИБО. ПРОШУ ПРОЩЕНИЯ, НАВЕРНОЕ, ЗАРАБОТАЛСЯ :(