Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Расчет суммы по формуле

Автор Woolfer, 27.12.2012, 02:20

« назад - далее »

Woolfer

Всем доброго времени суток!

Разберем задачу на примере: Имеется две ячейки. В первой ячейке(A1) целое число от 0 до 5. Во второй(B1) целое число>A1. Допустим, А1=1, B1=3. Тогда необходимо для чисел 3 и 2 высчитать в ячейке C1 такую вот сумму:
=2^3+2^2. Получается 12
При вводе чисел 2 и 4 необходимо высчитать такую же сумму для чисел 4, 3. (=2^4+2^3). При 0 и 5 для чисел 5, 4, 3, 2, 1. (=2^5+2^4+2^3+2^2+2^1). И так далее.

Старался ясно выразить свою мысль, не знаю, вышло ли. Но надеюсь на вашу помощь. Зашел в тупик :\



Михаил С.

Если я правильно понял, то
=СУММПРОИЗВ(2^СТРОКА(СМЕЩ(A1;A1;;B1-A1)))
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

IKor

Если допускается использование дополнительных ячеек, то формулы сильно упростятся...