Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

ПОИСКПОЗ() "не видит" цифры

Автор 0mega, 01.01.2013, 20:26

« назад - далее »

0mega

Доброго времени  суток.
Всех с новым годом.

Столбец "В" имеет произвольный буквенно-цифровой набор .
По первому символу определяется принадлежность к чему-либо. Если первый символ буквенный, тогда машина определяет принадлежность. Если первый символ цифра  - машина выдает #Н/Д

Михаил С.

С новым годом!
Для эксель число 1 текст "1" - это разные данные; либо измените формулу (массивный ввод),
=ИНДЕКС(H$1:H$16;ПОИСКПОЗ(ПСТР(B1;1;1);G$1:G$16&"";0))
либо вводите цифры в таблицу в текстовом формате.
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

0mega

#2
Михаил,  с праздником
Спасибо за ответ.
Парадокс в том что я пробовал менять формат на "Текст", но машина проигнорировала .


Михаил С.

формат "текст" надо ставить до внесения данных. Потом не помогает.
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

0mega

Спасибо, сейчас будем посмотреть

0mega

 С текстовым вводом пока не разобрался, а
ввод через Ctrl+Shift+Enter  тоже оказался недейственным...

Михаил С.

#6
Внимательно смотреть надо:
=ИНДЕКС(H$1:H$16;ПОИСКПОЗ(ПСТР(B1;1;1);G$1:G$16&"";0))

Цитата: 0megaС текстовым вводом пока не разобрался, а
Сначала устанавливаем формат ячеек "текстовый", потом вводим цифры. Или перед цифрой ставим ' (апостроф).
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

0mega

Цитата: Михаил С. от 01.01.2013, 21:53

G$1:G$16&""
Красивое решение .

ЦитироватьСначала устанавливаем формат ячеек "текстовый", потом вводим цифры.
тоже работает. Благодарю