Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Использование функции "=ЕСЛИ"

Автор Альфф, 19.01.2013, 01:52

« назад - далее »

Альфф

Доброго времени суток ув. форумчане!

Суть вопроса: имеется ряд столбцов, столбец "А" и три пронумерованных столбца 1,2,3 соответственно. Нужно перемножить столбец "А" на столбец №1,№2 или №3 и суммировать в зависимости от числа в ячейке над столбцом "А" (в примере эта ячейка выделена желтым).
Например если там цифра 1, то "А" * №1, если 2 , то "А" * №2.

то есть на выходе в ячейке будет ответ(число), если "А" * №1 , то =(А1*В1+А2*В2+А3*В3+...+А10*В10), поставим цифру 2 в желтую ячейку получим =(А1*С1+А2*С2+А3*С3+...+А10*С10)

В прикрепленном файле есть решение задачи с помощью функции "=ЕСЛИ", но столбцов будет не 3, а около 60 и получается уж слишком длинная формула.

Помогите, пожалуйста, решить данную задачу с умом!?

Прошу прощения за дотошное объяснение. В архиве два файла 2003 и 2007 экселя)

Буду очень признателен за любую помощь!)



Serge 007

=ГПР(A$2;C$2:E3;СТРОКА(A2);)*A3
=СУММПРОИЗВ((A$2=C$2:E$2)*C3:E3)*A3
=ИНДЕКС(C3:E3;;ПОИСКПОЗ(A$2;C$2:E$2;))*A3
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Альфф

Огромное спасибо уважаемый то, что нужноо!!!
Очень помог!