Порядок чисел (1,1,1,1,1,2,2,2,2,2,3,3,3,3,3 и т.д)

Автор trolmagnat, 22.01.2013, 14:19

« назад - далее »

trolmagnat

Почитал мануалы от мсофта, понял что их составлял бил и толку от них нет.

Нужен список с числами: (по пять чисел в ряд)
1
1
1
1
1
2
2
2
2
2
3
3
3
3
3
4
4
4
4
4
и т.д

Чтобы при перетаскивании маркера числа сами выставлялись.
Ну или ещё как автоматом.

Все стандартные способы не работают.

Задача кажется простой, но воплотить её почти невозможно.
Переубедите меня если сможете.

cheshiki1

#1
начиная с A2 формула =ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;A1)=5;МАКС($A$1:A1)+1;ЕСЛИ(A1=0;1;A1))
или в А1 вручную вписываем 1 тогда формула в А2 =ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;A1)=5;МАКС($A$1:A1)+1;A1))

Serge 007

Если надо с первой строки и одной формулой:
=ОКРУГЛВВЕРХ(СТРОКА()/5;)
=ОКРВВЕРХ(СТРОКА()/5;1)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390