Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Вывести среднее из буквенного значения

Автор Bolshoiman, 23.01.2013, 11:22

« назад - далее »

Bolshoiman

Приветствую всех! Помогите навести резкость в такой теме - есть ряд буквенных значений а именно : после анализа АВС по нескольким параметрам (делаю в ручную) остается скрепленные буквы например- авв, сва, аав и тд. Вопрос возможно ли одной формулой вывести из этих буквенных значений среднее - например АВВ - В. Заранее благодарен.

iron priest


_Boroda_

Если под словом "среднее" Вы подразумеваете букву, которая находится в середине трехбуквенной комбинации, то еще можно так
=ПСТР(A4;2;1)
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Bolshoiman

Нет не среднюю букву а именно если абстрактно сложить все три буквы и разделить на 3 - также бывает и пять букв = А+В+С=среднее буквой - тут явно В получается но вручную уже напрягает

cheshiki1


Bolshoiman

все формулы к сожалению только среднюю букву выдают

cheshiki1

а сколько вам нужно? вы про среднюю и писали или мы что то не до понимаем.
возникал такой вопрос если букв четное число то что выводить но ....

Bolshoiman

остается скрепленные буквы например- авв, сва, аав и тд.  - это и есть ряд буквенных значений, которые я имею ввиду - т.е. если когда требуется из цифровых значений выбрать среднее то 1+2+3 = 6 а среднее здесь 2. формула =СРЗНАЧ() а вот буквенное как усреднить - или это может невозможно? взываю к Вашему опыту.

_Boroda_

Если кол-во букв переменно, то весь этот бред примерно так описать можно
=СИМВОЛ(ОКРУГЛ(СУММ(КОДСИМВ(ПСТР(A1;СТРОКА(ДВССЫЛ("A1:A"&ДЛСТР(A1)));1)))/ДЛСТР(A1);0))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Bolshoiman

Спасибо _Boroda_, получается то что надо - вот если бы еще возможность была чтобы кирилица АВС распознавались а не латиница тогда вообще отлично , ну если нет то и за это Большое спасибо.

cheshiki1

формула распознает и кириллицу и латиницу вот только при совместном использовании обеих шрифтов в одной ячейке ответ будет не тот который вам нужен.

runner

Среднее буквенных значений... сильно! :)
Может это было нужно - МОДА?

=СИМВОЛ(МОДА(Ч(КОДСИМВ(ПСТР(A1;1;1)));Ч(КОДСИМВ(ПСТР(A1;2;1)));Ч(КОДСИМВ(ПСТР(A1;3;1)))))

хотя "АВС" не воспримет

Bolshoiman

Спасибо всем за сотрудничество! МОДА не работает в этой теме

MCH

Цитата: runner от 23.01.2013, 15:46
хотя "АВС" не воспримет
Вариант (воспринимает только трехбуквенные слова, при  трех разных буквах вернет первую):
=СИМВОЛ(МОДА(КОДСИМВ(ПСТР(A1&A1;{1;2;3;4;5;6};1))))

А что должно быть при "ABC" - "B"?
А если слово двухбуквенное, например "AC", ответ должен быть "B"?

Bolshoiman