Обратное действие в "ПОИСКПОЗ()"

Автор 0mega, 29.01.2013, 06:45

« назад - далее »

0mega

Доброго времени суток
2003
sub no

Есть столбец. Записи чередуются с пустыми строками.
Надо найти имя или номер позиции у n-ой занятой ячейки

Пример. Содержимое 3-ей занятой строки. Ответ МИР или 5 (по номеру позиции)

Текст 1
пробел
пробел
Тест
Мир

NooBasTiK

номер можно вот так выводить =ПОИСКПОЗ(D7;B7:B14;0)

_Boroda_

#2
например так
=НАИМЕНЬШИЙ(ЕСЛИ(A1:A17<>"";СТРОКА(A1:A17));7)
=ИНДЕКС(A1:A17;НАИМЕНЬШИЙ(ЕСЛИ(A1:A17<>"";СТРОКА(A1:A17));7))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Serge 007

Для разнообразия:
=СУММ((B7:B14=D9)*СТРОКА(1:8))
=СМЕЩ(B6;СУММ((B7:B14=D9)*СТРОКА(1:8));)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

0mega

Интересно получается...
Отвечали 3 человека, а стартовый файл скачан 2 раза ?!
Вы что, друг дружке по почте пересылали ?!

0mega

Сергей, в своих формулах (кроме одной) Вы привязываетесь к D9.
D9 и E9 - это те значения, которые я хочу получить .
Нужно не прязыватся к D9, а непосредственно в ячейке D9 написать формулу которая выдаст результат "Рис"
В данном случае, из предложенных 4-х, подойдет только одна Ваша формула
=ВПР(3;A7:B14;2;)



Serge 007

Извиняюсь, бегло посмотрел файл, "вывести имя" прочитал как "ввести имя"
Да и в топике не то что в файле, вот и сбило с толку :)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

cheshiki1

ЦитироватьОтвечали 3 человека, а стартовый файл скачан 2 раза ?!
если сразу жмешь открыть в эксель то это не считается скачиванием.

0mega

cheshiki1, здравствуйте
Цитата: cheshiki1 от 29.01.2013, 15:46
ЦитироватьОтвечали 3 человека, а стартовый файл скачан 2 раза ?!
если сразу жмешь открыть в эксель то это не считается скачиванием.
А с этого пункта , пожалуйста, подробнее...
Это куда и как ?
Лично у меня идет автомаматическая загрузка файла сразу же после нажатия ЛKМ

Serge 007

Цитата: 0mega от 29.01.2013, 16:05
с этого пункта , пожалуйста, подробнее...
Вопрос не имеет отношения ни к данной теме, ни к текущей ветке
Задавайте его в соответствующем разделе: Работа форума и сайта
Так как ответ на вопрос ТС есть - эта тема закрыта
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390