Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Логический выбор Если/IF

Автор Sergey Lyashenko, 29.01.2013, 21:28

« назад - далее »

Sergey Lyashenko

Здравствуйте,
Не знаю как реализовать следующее: нужно чтобы в каком-нибудь столбце(ну например в столбце K2) печаталось число в зависимости от столбца C2. Если число в этом столбце в диапазоне от нуля до 100 000 тысяч, то в столбце K2 должно быть число 0.5.
Если число в ячейке C2 в диапазоне от 100 000 тысяч до 1 000 000 то должно быть напечатано число 0.75.
Если число больше  1 000 000 то должно быть напечатано число 1.

Смог составить только такое условие
Цитировать=IF(C2>1000000;"1";IF(AND(C2>=0;C2<100000);"0.5";IF(AND(C2>100000;C2<1000000);"0.75";"0")))
Но он работает только если число больше 1 000 000
Подскажите как исправить?

_Boroda_

=ЕСЛИ(A1<100000;0,5;ЕСЛИ(A1<1000000;0,75;1))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

0mega

#2
В Вашем условии значения пересекаются :
100 000 относится  и к первому и ко второму условию
Так же и 1 000 000

К2=(C2<=100000)*0,5+(C2>100000)*(C2<=1000000)*0,75+(C2>1000000)
или так
К2=ВЫБОР(ПОИСКПОЗ(C2;{0:100000:1000000:999999999});0,5;0,75;1)