Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

В формуле при ссылке на ячейку писать номер строки в отдельной ячейке

Автор CorteX, 13.02.2013, 09:08

« назад - далее »

CorteX

Здравствуйте уважаемые форумчане.
Вопрос в следующем, может кто сталкивался
Необходимо что бы в формуле было прописанно не просто =А2 а вместо цифры 2 должна быть ссылка на ячейки в которой занесены данные на какую строку ссылаться. Желательно по возможности сделать это без макросов.
Приьлизительный пример желаемого в прикрепленном файле.

Jim

Хеллоу!

попробуй вот так:

=СУММПРОИЗВ(($D$2:$I$2<=$H$13)*СМЕЩ(C2;F12-2;1;1;6))

CorteX

Уря!!! Спасибо огромное, а я что то и не брал во внимание эту функцию! Благодарю!!!

CorteX

Один только недостаток, я эти формулы настроил так что они ссылаются на другие книги, и в тот момент когда они закрыты формула не работает выдает знач  :'(