Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Вопрос по функции ЕСЛИ

Автор Максим Кабанин, 19.02.2013, 14:12

« назад - далее »

Максим Кабанин

Не разберусь как написать такое вот выражение, 2 часа голову ломаю, с экселем работаю редко.

Если ЯЧЕЙКА F1 меньше или ровна 250, то = 2, если Ячейка F1 в диапазоне от 251 до 800, то = 3, если Ячейка F1 в диапазоне от 851 до 1500, то = 4, во всех остальных случаях, =5


runner

Единственно, У Вас разрыв между 800 и 850 (я его своевольно свёл к точке 850 :) )

=ЕСЛИ(F1>1500;5;ЕСЛИ(F1>850;4;ЕСЛИ(F1>250;3;2)))

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Wasilic

Если через ЕСЛИ:
=ЕСЛИ(F1<=250;2;ЕСЛИ(И(F1>250;F1<800);3;ЕСЛИ(И(F1>850;F1<1500);4;5)))
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

Максим Кабанин

Цитата: runner от 19.02.2013, 14:22
Единственно, У Вас разрыв между 800 и 850 (я его своевольно свёл к точке 850 :) )

=ЕСЛИ(F1>1500;5;ЕСЛИ(F1>850;4;ЕСЛИ(F1>250;3;2)))

Не знаю как это работает, но РАБОТАЕТ. :) - Спасибо.

Можно теперь тупой вопрос:
нужно все тоже самое но до 10:

250 - 2 мес.
800 - 3 мес.
2000 - 4 мес.
5000 - 5 мес.
8000 - 6 мес.
12000 - 7 мес.
16000 - 8 мес.
20000 - 9 мес.
25000 - 10 мес.
30000 - 11 мес.
35000 - 12 мес.

И если можно ли строку перевернуть,

не:
F1>1500;5;ЕСЛИ(F1>850

а:
F1>850;4;ЕСЛИ(F1>1500

и чтоб работало )

Максим Кабанин

Цитата: Wasilic от 19.02.2013, 15:11
Если через ЕСЛИ:
=ЕСЛИ(F1<=250;2;ЕСЛИ(И(F1>250;F1<800);3;ЕСЛИ(И(F1>850;F1<1500);4;5)))

Да да, это тоже подходит, отлично...можно только до 12 мес так же сделать...и последовательность правильная

Wasilic

Сразу надо оговаривать. ЭКС 2003-й допускает только 7 вложений.
Используйте
=ПРОСМОТР(F1;{0;251;801;2001;5001};{"2 мес";"3 мес";"4 мес";"5 мес";"6 мес"})Остальное сами продлите.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

Максим Кабанин

Цитата: Wasilic от 19.02.2013, 15:36
Сразу надо оговаривать. ЭКС 2003-й допускает только 7 вложений.
Используйте
=ПРОСМОТР(F1;{0;251;801;2001;5001};{"2 мес";"3 мес";"4 мес";"5 мес";"6 мес"})Остальное сами продлите.

Объясню почему не подходит:
В итоге формула получится должна такого вида: 2 мес - Ячейка D1; 3 мес - Ячейка D2...а диапазоны от и до будут тоже ячейками, чтобы можно было отредактировать одну ячейку, и все формулы пересчитали по новым диапазонам с количеством месяцев.

Serge 007

#8
Цитата: Максим Кабанин от 19.02.2013, 15:41
...формула получится должна такого вида: 2 мес - Ячейка D1; 3 мес - Ячейка D2....
Для этого в правилах есть такой пункт:
К первому сообщению темы должен быть прикреплен файл примера в формате xls*

Так правильно:
=ПРОСМОТР(F1;{0;251;801;2001;5001};D1:D5)
А если "диапазоны от и до" тоже будут ячейками, то так:
=ВПР($F$1;$C$1:$D$11;2)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Максим Кабанин

Вот пример

Максим Кабанин

Цитата: Serge 007 от 19.02.2013, 16:38
Теперь-то чего его выкладывать?
Вам уже не только несколько вариантов решений предложили, но и даже в файле решение выложили

ну почти да...как теперь к =ВПР(F1;A2:B12;2) прилепить "мес." чтоб было в одной ячейке? и при вводе суммы 250 и меньше, возникает ошибка и при вводе суммы более 35002 пишет 12мес, а надо чтоб писал договорная

В любом случае, Все Вы мне очень помогли, огромное спасибо всем.

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Максим Кабанин

Если ввести сумму:
250
800
2000
5000
8000
12000
16000
20000
24000
28000
32000

выдает не правильный месяц

Serge 007

Какую сумму? Куда ввести? Где и кто "выдаёт"? У Вас с русским языком напряги? Мысль внятно изложить можете? Если нет, то прикладывайте файл с проблемой

ЗЫ Блин, вопрос решается трёхминутным чтением справки по ВПР(_), а мы пол-дня тему мусолим
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

cheshiki1

подправил таблицу чтоб формулы простые были (предложенные выше).
или таблицу править нельзя?