Сумма ячеек кроме ячеек из определенных строк

Автор Алексей Гурин, 10.03.2013, 19:35

« назад - далее »

Алексей Гурин

Здравствуйте.

Имеется таблица
                            A                   B      C      D
1           23 февраля 2013 г.    89100   17,5   500 
2           26 февраля 2013 г.    89200   17,5   500 
3           2 марта 2013 г.           89300   35,7   1 000 
4           10 марта 2013 г.           89756   17,2   500 

Нужно посчитать сумму 4 столбца, НО кроме последнего ряда, то есть должно получится 2000.
Поидее наверно надо взять сумму сначала всего столбца и вычесть ячейку из строки с максимальной датой или макс столбцом B, но как?

Poltava

Вы пример конкретный давайте! судя по всему тут есть какие то заморочки иначе вы бы использовали стандартную функцию сумм. А так мы не ясновидящие и не можем понять задачу по неполному условию. Ведь непонятно всегда ли вычитать последнию, или наибольшею или еще как куда выводить результат в общем дополняйте задачу конкретикой и ФАЙЛОМ с примером
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Алексей Гурин

Хорошо. Приведу конкретную задачу. Мне нужно посчитать Сумму столбца C кроме строки с максимальной датой. То есть в данном случае: 17.5 + 17.5 + 35.7. Последнее - 17.2 не считаем, т.к. число находится в строке с максимальной датой в столбце А. Столбец А не обязательно упорядочен, так что =СУММ(C:C)-C4 будет работать только с упорядоченным столбцом.

Poltava

#3
Я вижу Вы упорно не желете выполнять правила форум и тонкие намеки о том что нужен фай Вы не понимаете! за вас рисовать таблички нет ни времени ни желания это раз во вторых это снимает множество вопросов о том в каком виде исходные данные куда выводить результаты и как потом это применять!
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

zs

а лучше Ваше предложение пишете в формулах, z.b.

Алексей Гурин

Poltava, спасибо большое! То что надо. К сожалению у меня не было под рукой в тот момент excel, я писал с телефона.

Алексей Гурин

#6
Вот еще 1 табличка.
A                                 B
23 февраля 2013 г.   500 
26 февраля 2013 г.   500 
2 марта 2013 г.   1 000 
10 марта 2013 г.   500 
23 апреля 2013 г.   750 
26 апреля 2013 г.   800 
2 мая 2013 г.   850 
10 июня 2013 г.   900 
23 февраля 2014 г.   950 
26 февраля 2014 г.   1 000 
2 марта 2014 г.   1 050 
10 марта 2014 г.   1 100 
23 февраля 2014 г.   1 150 

Нужно посчитать сумму или среднее значение(не важно, мне лишь бы понять как) по месяцам. то есть напрмер суммировать все ячейки для февраля. у меня получилось сделать с жестко заданной датой (или как вариант я создал фиктивный столбец, где высчитывался месяц и скармливал его SUMIFу). Вот хоть убейте меня, я не пойму можно ли функции СУММАЕСЛИ, у которой первый параметр диапазон, скормить не чисто диапазон в сыром виде, а прогнать его через функцию МЕСЯЦ и уже потом сравнивать.
в моем понимании это выглядело бы так для февраля =СУММЕСЛИ(МЕСЯЦ(A:A);2;B:B), но это не работает(
зато работает если создать еще столбец C, где значениями будет МЕСЯЦ от A и тогда функция =СУММЕСЛИ(С:C;2;B:B) заработает как надо, но это же некрасиво :(

Poltava

Может и не лучший вариант но первое что пришло в голову, пример для марта
=СУММПРОИЗВ(--(МЕСЯЦ(A1:A13)=3);B1:B13)/СУММПРОИЗВ(--(МЕСЯЦ(A1:A13)=3))
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

zs

может быть через выпадающий список

_Boroda_

=СРЗНАЧ(ЕСЛИ(МЕСЯЦ(A1:A13)=3;B1:B13))
формула массива, вводить одновременным нажатием Контрл Шифт Ентер вместо просто Ентера
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995