Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Добавление нескольких независимых условий

Автор Владислав Гречихин, 13.03.2013, 12:40

« назад - далее »

Владислав Гречихин

Коллеги, такой вопрос.
Выдаю пример базы. Необходимо подсчитать по номерам абонентов (столбец Р):
а. сумму разговоров (столбец Н), совершенных абонентом (столбец D) на мобильные операторы (столбец F). К мобильным операторам относятся: "=КиївСт*", "=Umc*", "=Астеліт*", "=*091", "=*092*" "=*094*", "=Джинс*"
b. количество разговоров (столбец Н), совершенных абонентом (столбец D) на мобильные операторы (столбец F). К мобильным операторам относятся: "=КиївСт*", "=Umc*", "=Астеліт*", "=*091", "=*092*" "=*094*", "=Джинс*"
При этом структуру БД менять очень нежелательно.
Очень нагромождает формула =СУММЕСЛИМН($H$2:$H$10000;$D$2:$D$10000;P2;$A$2:$A$10000;"=КиївСт*")+=СУММЕСЛИМН($H$2:$H$10000;$D$2:$D$10000;P2;$A$2:$A$10000;"=Umc*") и т.д.
Краткий смысл - узнать возможность добавления смежных условий, каждое из которых является истиной.
Спасибо!

TimSha

Цитата: Владислав Гречихин от 13.03.2013, 12:40
... Необходимо подсчитать/просуммировать определенные ячейки...
Изобразите, пожалуйста, в файле с реальной структурой и форматами данных что из чего куда  да как надо получить...
Заочно/угадай-ка - сводной таблицей...
ps В старых темах не мешало бы отписываться - решено/не решено.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)